update-notifications.php calls depricated is_site_admin in wp 3.0.1 multisite

Just installed Product theme with WordPress 3.0.1 multisite. Added "update-notifications.php" to /wpcontent/mu-plugins. I am running in debug mode and receive the following error:

Notice: is_site_admin is deprecated since version 3.0! Use is_super_admin() instead. in C:\xampp\htdocs\wp30test\wp-includes\functions.php on line 3237

and

Notice: is_site_admin is deprecated since version 3.0! Use is_super_admin() instead. in C:\xampp\htdocs\wp30test\wp-includes\functions.php on line 3237

to fix, updated "update-notifications.php" to include the following changes:

Lines 263, 384, 403, 417, 495:

Changed
if ( is_site_admin() ) {

to

if ( is_super_admin() ) {

This resolved the issue. Can you check me on this.

Thanks, Brannon