Update Screwed My Entire Site Images UP!!!!

DANG IT!!!! I updated the plugin and for some reason it replaced all the images on my site or most of them with the wrong url... so now instead of the image url its showing the download url instead of the correct url. I have no clue why it would do this but please help... this site needs to be working by the morning as we have customers going to this site every day. Please advise quickly!

  • Sajid

    Hi Jason! Hope you are doing good and sorry for inconvenience!

    I will report this behaviour to our developer and will get back to you shortly. Meanwhile you can downgrade to previous version of this plugin. You can download previous version on project page by clicking on changelog (see screenshot).

    I also noticed that you have staging website setup. Update this plugin on staging website and grant me support access by following the steps mentioned in this manual. So we can further troubleshoot this problem.
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Take care and have a nice weekend :slight_smile:

    Cheers, Sajid

  • Sajid

    Hi Jason! Welcome back :slight_smile:

    Its okay! I am moving this thread to correct forum and we can continue this thread.

    For URL issue just a heads up, it can be due to media protection add-on. You can change the protection method from "Complete protection" to "Hybrid protection" or use "Basic protection (default)". You can find this menu from Admin > Protect Content > Add-ons > Media Protection > Details.

    Hope this helps and have a nice weekend :slight_smile:

    Cheers, Sajid

  • Jason

    Thank you for your response, I did as you advised but its still protecting all the images on the site. Not sure what I am missing here?

    Going to disable the media add on for now, but can you go and help me with the settings for this because I cannot figure it out. This was not a issue at all before I updated the plugin so not sure what changed with the code of this plugin.

    It needs to protect the media I chose not default to protect everything.

  • Sajid

    Hi Jason! Hope you are doing good :slight_smile:

    I can see media protection add-on is enabled and your site is working fine to me. All your images are working and displaying on frontend. When you add media protection, then download URL mask is required. This will simply hide the uploads folder but not restrict its access. Visitors can still see the images.

    Now you can protect individual images to protect from visitors and grant access to members. From Protect Content > Protected content > Media Library Items.

    If you still getting issues. I suggest you to run a quick plugin conflict test by following the steps mentioned in "Flowchart" of this manual and provide us more details regarding this issue with the help of screenshots. This will help us narrow down the issue. If you have any cache plugin then I suggest you to clear cache first and then deactivate this plugin.
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Look forward towards your response :slight_smile:

    Cheers, Sajid