Update Ultimate Branding disable modules

Hi. I'm very happy to join your community. I have to test some plugins on my sandbox. And as we update wordpress and extensions with wp-cli and github or svn, for WPMU plugins we use ssh put the zip and unzip its folder.
With Ultimate branding, I had activate all the module and the last update have disable all the modules except 3 or 4 ones.
As we have to use it on a 4500 blogs multisite, i would like to know if this is normal and what other way i have to choose. Thanks.

  • Adam Czajczyk

    Hello Tam

    I hope you're well today and thank you for your question!

    The modules shouldn't be disabled upon update. I also checked our internal bug reporting system but I don't see any similar issues reported so far. I'd say that such thing could possibly happen if there's been some error during update or something's been "messed up" in the database.

    This brings me to the way you are updating WPMU DEV plugins. In many cases simply updating plugin files (either via FTP or the way you do it - put the zip file on server and unzip it to correct location) would work but it does create a risk because sometimes updates carry more changes and those might require e.g. db updates or affect plugin performance in other way. It probably would be better to use our Automate to trigger those updates then so the update was actually performed by WP itself.

    This was updated on Multisite, correct? Was the Ultimate Branding network-activated there? Do you recall what modules were disabled?

    Also, from which version to which version did you update the plugin?

    I'm asking because I'd like to test it but it's also worth noting that in the last release three new modules were added ("Document", "Signup Code" and "Tracking Codes") and one was removed - or rather combined with another one - ("Login CSS", now within "CSS") and those new modules are not active by default so that could as well just "make an impression" of modules being deactivated, so I'd like to make sure about it :wink:

    Best regards,
    Adam

  • Tam

    Hi and thanks for your answer.

    Yes multisite, of course plugin network activate.
    Update from 340566_ultimate-branding-2.1.zip to 2.3
    All the modules were disable except
    dashboard welcome
    Admin bar logo
    Email from
    Author box
    SMTP and Signup Code (this 2 were disable before)

    I have lost too the config of disable options

    We can't use your automate on our very secure servers with nginx, mariadb and varnish... :disappointed:
    For the moment it's only to test on a sandbox, but at least it was fine if we could update via wp-cli and an autenticated svn for example. I have to talk about that with my sysadmin.

    Edit : My sysadmin tell me he have made a rm before upload the new one, it's probably for that :disappointed:

  • Predrag Dubajic

    Hi Tam,

    Thanks for the additional information, I would like to do some tests on my end but would like to know a few more things.

    After the plugin was removed via SSH was is also uploaded back to plugins folder and then unzipped with unzip command or was it reuploaded via WP admin Plugins panel?
    If unzip command was used was the Plugins panel visited between the time that the plugin was removed and reinstalled?

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Tam,

    Thanks for the additional information, however, I'm afraid that I can't replicate this issue when updating from 2.1 to 2.3 by using SSH.
    I tried with just removing UB folder of 2.1 version and then unzipping 2.3, but I also tried removing the plugin, visiting Plugins panel in WP and then unzipping 2.3 but this also didn't disable any of my settings.

    Do you perhaps have a staging site where you can revert to 2.1 and test this there, and then also test by updating to 3.0 that we released today?
    Does the same issue happen there and does it happen with an update to 3.0 as well?

    During this can you get the exact steps and commands that were performed and hopefully I would be able to replicate it with that in order to try and pinpoint the cause of this.

    P.S. Do you have any DB cleanup tools that might have been running during the switch?

    Best regards,
    Predrag

  • Tam

    Hi guys
    \o/
    All is ok updating 2.3 to 3

    git fetch -a
    git checkout -b wp5.0.3-3 (local modifications still be there)
    scp zip to server's /tmp
    unzip tmp/ultimatebranding.zip
    rm -rf wp-content/plugins/ultimate-branding
    cp -R /tmp/ultimate-branding wp-content/plugins/.

    All my settings are still here !!!
    So we don't know what's happened for the previous.... sorry for the noise

    And so i have tested version 3... good job ! Bravo

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.