updated page in menu - error resulted in total loss of menu page display

Mac OSX 10.6.8 on 3.2GHz intel. Safari 5.1.5. Nebulae, Gantry, menus

http://www.oldbike.eu/museum/

I wrote 2 new pages today. First uploaded in menu pages OK. But second one did not - selected it in ADD TO MENU box so that it appeared at the bottom of the menu items; then moved it up to its new location and clicked SAVE MENU as usual. But then error message appeared THE GIVEN OBJECT ID IS NOT THAT OF A MENU ITEM and i've now lost the entire menu display on the blog and access to my website pages. Only part of the menu list still appears in the wp-admin/nav-menus.php page.

I have copied the pages i wrote today to another blog. And I backed up this blog yesterday.

I've never reinstated a blog from a back-up. Will it recreate my menus to time of save? (Scared to try it!) And would it involve more re-writing of the blog than the 5 or 6 hours necessary to manually load all my 203 pages into the menu system?

I did have this error when I first changed to this theme/gentry/menu system. It happened repeatedly and the only way round it was to 'save menu' frequently with only 5 or 6 page insertions at a time. But this is more critical as obviously entire page menu rebuild is long-winded.

Thanks for your assistance

Colin

  • aecnu

    Greetings Colin,

    Sorry to hear about this tragedy which is the first time I have ever heard of something like this happening.

    I've never reinstated a blog from a back-up. Will it recreate my menus to time of save? (Scared to try it!)

    Unknown since I do not know when the backup was made, therefore if the menus were made before the backup was made, yes they will be there, if after they probably will not be there.

    I you fear restoring the original backup from yesterday, then it would be in your interest to create one today so you can restore it to current time if necessary.

    And would it involve more re-writing of the blog than the 5 or 6 hours necessary to manually load all my 203 pages into the menu system?

    I would think, depending on the server involved and its capabilities, it may take just 5 to 6 minutes to restore the site or possibly even less time. Certainly more efficient then to manually load I am certain.

    Please advise how it goes.

    Cheers, Joe

  • Lovedubs

    I assume the previous back up will overwrite the current blog? (which is what i need)

    ie it would not create duplicate pages, or some other thing that takes time to remedy?

    I tried to upload the back up file - but got this

    Sorry, there has been an error. File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

  • Lovedubs

    I also tried a plug-in 'portable PMA' but that upload gets an error too - 'You probably tried to upload too large file.'

    Back-up file is 13.9mb

    can't see any way to amend file size limit in ftp import.php

    support forums only seem to have info on this issue from over 2 years ago

    It's bad enough this nasty bug in menus blowing out most of my pages, but when I can't restore my back up file either i may as well take the blog down!

    Any help would really be appreciated...

    (and would be good to keep on file for when other users face this problem)

  • aecnu

    Greetings Lovedubs,

    Have you uncompressed the backup to your computer and then tried FTPing it to your site overwriting all that is there?

    Have you contacted your host and asked them how to restore the backup?

    We could go through many things trying to figure this out concerning the backup, but the host should be able to take a look and should be able to tell you in one minute what the problem is concerning restoration of the backup and offer the fix.

    It could be anything from space to php.ini settings.

    Please advise.

    Cheers, Joe

  • Lovedubs

    Unfortunately my host support does not support wordpress. (Do any?)

    The .xml file would not uncompress using my stuffit expander, but I have ftp'd the back-up .xml file as is although I don't know where to put it. It didn't make any difference in the folder of the blog name. So I tried three times, putting a copy of the back-up file into 3 locations within that folder - wp-admin, wp-content and wp-includes. Again no difference.

    Ideal solution would be to amend the upload file size limit in php.ini. However, I can not find a file entitled php.ini though I have looked as that was the file name referred to in forums. The closest i could find is import.php though this does not show any facility for adjusting import size settings. Where can I find the php.ini file?

    The host support said there is no limit on size of import files for ftp.

    Thanks

  • Lovedubs

    I've cancelled my subscription to WPMU.

    I can't see any point in paying a monthly subscription when no support is provided.

    Joe/ aecnu - if you have no experience of the gantry menu systems crashing and wiping out most of the menu system on a blog, despite this error occurring both to me and other users, wouldn't it be more useful to find a member of the support team who has worked on this sort of issue before?

    Re-installing a back-up from a wordpress blog is not straightforward. Wouldn't it be useful to help someone do so when they need to?

    Plus, you know it is the gentry menu that has failed. I told you that it takes a long time to re-create the menu manually.

    So, now for the million dollar question - would re-installing a back-up re-install the menu layout? Or is the gantry menu system a plug-in that is not possible to save as a back-up?

    In other words, have i been wasting my time trying to reinstall the back-up when there is no point?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.