Updated Plugins and website no longer accessable

Hello,

My problem has started when I updated the WPMU DEV plugins. As soon as the update processed it went to a blank screen and I can no longer access the website at all - I get a white screen or a 500 error.

  • Kasia Swiderska

    Hello marthus,

    First we need to check what plugin is causing this. So debug mode needs to be enabled. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see contents of the debug.log file - if it's short you can past it here, but when is large file please paste it to the text file and attach to post.

    When you have debug log, you can connect to FTP and then disable plugin that is causing this issue by renaming its folder name - it will instantly disable it.
    You can also change name for whole plugins directory so this will disable all plugins, if you are not sure what plugin is causing this error.

    kind regards,
    Kasia

  • marthus

    Hello Kasia,

    First, thank you for the very prompt reply; i do very much appreciate it! I added all of the code you suggested and then went to the WP-Content file and opened the debug.log and found this:

    [12-Jan-2016 18:24:06] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home7/ittlegs1/public_html/wp-content/themes/upfront/library/servers/class_upfront_javascript_main.php on line 229

    Is this what you are looking for or should I look elsewhere as well?

    Cheers,

    Mark

  • Rupok

    Hi marthus

    I hope you had a wonderful day.

    As you are getting "T_PAAMAYIM_NEKUDOTAYIM" error, there is a huge chance this is being caused by the PHP version of your server and I assume, your server is still using PHP v5.2 .

    Can you please ask your hosting provider to update the PHP version in your server? I highly believe, this will fix your issue.

    Please let us know if it doesn't solve your problem. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.