updates to my server not working

hi folks. some of my domains are hosted on other servers, most on mine. my server eats the centralized updates from hubs.

what can i check?
i have whitelisted the wpmudev IP?
what else is on the short list?

  • Rupok

    Hi Symi,

    my server eats the centralized updates from hubs

    Can you please tell us a bit more about the issue? I mean what error do you see when you try to update from the Hub? Can you please provide any screenshot? Can you download plugins through WPMU DEV Dashboard plugin on those sites? Can you also update plugins/themes through DEV Dashboard on those sites? You said you have whitelisted our IP address but can you please confirm with your host that there is no blockage in any other way in communication from your server to our servers?

    Please send us as much details as you can. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Symi

    Hello Rupok

    OK - something seems to have changed, because I had run the backups off the hub before, and it worked. now when saying "update everything", it comes back with "some updates failed" on every single domain hosted on my server. :slight_smile: but - pretty much immediately.

    I quickly tested, logging into /wp-admin on any of my sites gives me normal access to updating plugins either from the wpmudev dashboard, or from the normal update page where you can run wp & plugin updates.

    it seems that the individual sites, when logged in and doing an update, works fine.
    but the automated version doesn't from the wpmudev hub?

    Also - in the report after the automated run - it gives me the option to click on the button that takes me to the domain/wp-admin/
    the moment i clicked that, i think it picked up the clicked link as the referrer, and it blocked my IP.

    So somewhere, it's feeling all violated!

    I'm checking modsec logs and such to see if i can find out why it got annoyed.

    any ideas?

  • Nithin

    Hi Symi,

    Hope you are doing good today. :slight_smile:

    I was able to get a feedback from the developer regarding this, and both the issue that you have mentioned ie the Some updates failed message, and the IP being blocked seems to be something to do with your firewall settings. As we don't have control over this, could you please check whether this is the case? If not sure, please check this with your host, and see whether the server is blocking anything.

    Kind Regards,
    Nithin

  • Symi

    Hello Nithin , so -
    I am running modsec security / firewall / cpanel hulk,
    on the firewall & hulk i've whitelisted the IP.
    on modsec I've checked the logs for anything that notes the IP of wpmudev, but no joy - can't see any hits.

    when trying to manually run an update, (a single one) from the hub, this is what i'm getting:
    We did not get a response from your site yet. The update might still be in progress, visit your dashboard to confirm.
    You can always simply update via your dashboard.

    when trying to check uptime from thehub:
    Your domain does not appear to be publicly accessible on the Internet. We can only monitor the uptime of public websites.

    can you please confirm with me which IP is being used to check if a site is available?
    if it's 66.135.49.214 - my server is quite happy with it as it lives in the US.

    any ideas?

  • Symi

    Hi WPMUDEVers, I ran the issue past the crew at CPanel, and this is their feedback:
    They looked at 2 things:
    when trying to run an update on one domain from the hub, it says it can't get a response from my domain, and when trying to scan my domain from wpmudev, it says it is possibly not a public-facing domain. this kind of ties in with the issue of not being able to run updates from wpmudev hub?

    I've also run through each and every log on the server, and tried to find the spot where I block you. I"m not seeing it!

    Can you guys have a lookie see on your end?
    :slight_smile:

    FROM CPANEL:
    Thank you for contacting cPanel support. I have taken a look through the logs on the system (/var/log/messages, /usr/local/apache/logs/eror_log, /usr/local/cpanel/logs/cphulkd*, /usr/local/cpanel/logs/error_log and /usr/local/cpanel/logs/access_log) and I could only find the IP in the cPanel access_log but it looks like it was only related to be whitelisted in CSF and looked up in the CSF log. You may want to reach out to the developer/support team of the WordPress software you're using to see if they're seeing any blocks on their end or possibly DNS issues which is preventing them from looking up the domain. At this point I see no issues with the cPanel / WHM software or it's configurations.

    If you have any other issues or questions please let us know.

  • Kasia Swiderska

    Hello Symi,

    As requested I send message to our developer to check your IP address if its not blocked by any chance on our side.
    I'm still waiting from response from our sysadmins.

    In the meantime, could you tell me what example site is not working with updates? You can leave support access open to that site if you dont want to share url here. If the IP is not problem I'll show URL to our admins and we will see what can be there wrong.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.