Updates via The Hub not working

Updates via The Hub are not working across any of my sites (I have 50+ sites connected). Getting error that says could not copy files on every single one I try, even on WPMUDEV's own plugins.

Can anyone else confirm this issue, or provide an ETA on when it might be resolved? I have a few things with fairly critical updates that need to be completed and I'm not looking forward to logging into all 50+ sites separately to do so.

Thanks!

  • Nithin
    • Support Wizard

    Hi Rhonda,

    The updates work fine for websites hosted with WPMU DEV. Could notice the issue with websites hosted in the other server. Are all these sites hosted with the same hosting provider?

    Such an issue could happen if there is a scanner or something specific in the server-side which is blocking it.

    Could you please ask your hosting provider to whitelist the following IP, and see how it goes:

    18.204.159.253
    165.227.66.214
    45.55.78.242
    35.171.56.101 
    
    192.241.140.15
    104.236.132.22
    192.241.148.18
    34.196.51.17
    52.57.5.20

    Please let us know how that goes so that we could check further if needed. Have a nice day ahead.

    Best Regards,
    Nithin

  • Rhonda
    • Unicorn Wrangler

    WP Engine has escalated my ticket to dig deeper on the issue... Hopefully they can resolve! This is the first time I've had this problem after over 2 years of updating via the hub on these same sites so I am a little perplexed.

  • Nithin
    • Support Wizard

    Hi Rhonda,

    Did you clear the cache in the WP Engine side once the IPs were whitelisted? Could you please point out on which site the IPs were added so that we could specifically check that site, and troubleshoot it further?

    Once the cache is cleared, and still, the same issue occurs then please do enable debug mode. To enable it, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );
    define('WPMUDEV_API_DEBUG', true);
    define('WPMUDEV_API_DEBUG_ALL', true);

    After making the above changes, please try to run a plugin update via Hub, and also via dashbaord. The related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Also please do enable support access to your website once you share the debug.log file too. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know how that goes.

    Kind Regards,
    Nithin

  • Rhonda
    • Unicorn Wrangler

    Still working on this with WP Engine and not feeling like there has been much progress so far. We pushed one of my installs there to staging for troubleshooting and this is the latest thing that I have heard from them:

    We have started the trouble shooting on the staging site jlebowstage and can see there was a following php fatal error coming from theme and changed the theme to default and still the issue persisted.

    4 PHP Fatal error: Uncaught Error: Call to undefined function get_header() in /nas/content/live/jlebowstage/wp-includes/theme-compat/embed.php:13\nStack trace:\n#0 {main}\n thrown in /nas/content/live/jlebowstage/wp-includes/theme-compat/embed.php on line 13
    We have changed the .htaccess to default and have commented out the lines in the wp-config that might be effecting these function.

    We have also disabled the plugin wp-defender which generally causes these issues and still there was no result .

    I have taken a back up of the site before I have started making these changes and have left the changes for you look at .

    I tried updating the plugins Hustle Pro, Smush Pro, WPMU DEV Dashboard manually in the dash board . However, I am unable to update these plugin's on Wordpress dashboard as well.

    We could not find any errors that are related to the issue on the server end.

    Can you reach out to plugin developer and confirm if they require any permissions that needs to be enabled on server end and they must be able provide resolution for the issue.

    They whitelisted all of the IPs you provided after that and it appears that they were then able to update WPMUDEV plugins, but not others (for example, that install had a Yoast update available but they were not able to do an update on that unless it was done manually from the individual site).

  • Rhonda
    • Unicorn Wrangler

    Additional response from WP Engine re: results of whitelisting IPs:

    So those IP addresses were not whitelisted for the jlebowstage, I went ahead and added them to our nginx rules, and I was able to update everything except the Yoast plugin with wpmudev (I think Yoast needs to be done manually). This is what is currently whitelisted on jlebowstage and hmgacademy:

    allow 18.204.159.253;
    allow 165.227.66.214;
    allow 45.55.78.242;
    allow 35.171.56.101;
    allow 192.241.140.15;
    allow 104.236.132.22;
    allow 192.241.148.18;
    allow 34.196.51.17;
    allow 52.57.5.20;

    I didn't remove any of the custom defines in the wpconfig, so in this case it looks like the IP's were all that was needed. What kinda of access does wpmudev need? It might be worth it for us just to whitelist those IP's server wide instead of a per install basis since you have so many installs that need the IP's whitelisted.

  • Rhonda
    • Unicorn Wrangler

    The latest I have received from WP Engine as they try to troubleshoot the issue:

    Its very possible that WPMUDEV is attempting to write to a part of the server that does not support remote connections or requests. Would you be able to inquire on whether they are attempting to write directly to the database? This would be an issue as we do not allow for remote access to databases for security purposes.

    Any and all information you can obtain would greatly benefit us and our investigation.

  • Ash
    • WordPress Hacker

    Hello Rhonda

    Hub doesn't write directly into the database during the update process. It sends a remote connection to the site where our Dev Dashboard plugin is installed and active and then it triggers the update process from the site. Also, as you said that you used to update those sites earlier and WPE never allowed to write in the database, so I don't think that's the issue here.

    So, whitelisting the IPs fixed the issue finally?

    Cheers,
    Ash

  • Aaron
    • CTO

    So sorry for all your trouble! We managed to trace this down to a regression in our own Hub code that we introduced accidentally when we upgraded our servers to PHP7.3. QA tested hub updates, but we missed this edge case with the special workarounds we have to do for WP Engine security configs.

    All should be working from now on. You may have to reenable Automate for some sites if they turned off due to too many failures.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.