Updating Appts in Admin end keeps on hanging

Hello,

I am trying to update appt times/information in the WP admin backend and when I click on save/update button the page just hangs.

There is a "thinking" wheel next to the cancel button but the page won't reload/confirm the changes. When I refresh the page, it looks like the information saves but I am not sure if emails are being sent out and the information is being committed.

I have enabled support access in case you want to take a look

Thanks,
Judah

  • Michael Bissett

    Hey @Judah, hope you're doing well today! :slight_smile:

    I'm not able to reproduce this on my own test site, but while looking into this issue on your site (which took a bit, seems like the site's pretty slow right now), I did notice that when I tried changing the appointment time, the time was updated, but the confirmation email wasn't sent out (I checked the box for (Re)send confirmation email).

    On further investigation, I noticed that there was a 500 Internal Server error showing up in the browser console when I updated the information. I also noticed that the log is empty inside of:

    Appointments -> Settings -> Logs

    There should be some sort of activity in there (e.g. an appointment confirmation, an appointment status change)

    A simple thing I would try would be to increase the amount of memory available to WordPress, by inserting a define like this:

    define( 'WP_MEMORY_LIMIT', '512M' );

    Next, I'd want to check for conflicts, as it's possible that we've got one on our hands here (either with another plugin, or perhaps the theme itself). We've got our handy troubleshooting flowchart at the bottom of our Getting Support page here:

    https://premium.wpmudev.org/manuals/getting-support/

    Let me know if this helps please! :slight_smile:

    Kind Regards,
    Michael

  • Judah

    Hey @Michael,

    I think you were testing the website when I was making changes.

    On further investigation, I noticed that there was a 500 Internal Server error showing up in the browser console when I updated the information.

    The above only happens when I click "see details and edit" -> save or when I try to manually add a new lesson in from the admin end.

    When I tried to make a new appt from the admin end it took about to minute to send the email but I am still seeing the waiting ball hanging even after the email was sent and I got the selected records updated confirmation up top.

    While it was process I did receive the following console error.

    I also noticed that the log is empty inside of:

    I think this is where we must have overlapped? I am seeing plenty of logs going on.

    I tried to increase WP memory load but that did not solve the problem.

    When I changed the theme to 2015 and tested it out, I was still getting the same issue.

    I am still working with the ServerPress team on setting up a local environment so I will add this issue to the list of items that need to be tested (removing all plugins- can't do that on a live site).

    If you have any other ideas please let me know,

    Thanks,
    Judah

  • Judah

    Hey @Michael Bissett,

    I checked all of the error_log's I could find on the server and found nothing recent.

    Here is a screenshot of the 500 Error I get. I only get it the second after I push the Save/Update button.

    Here is link to pastebin in case the code does not come out properly below:

    POST http://www.spanishvirtually.com/spanishvirtually/wp-admin/admin-ajax.php 500 (Internal Server Error)send @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,plupload,json2,jquery-u…:4m.extend.ajax @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,plupload,json2,jquery-u…:4m.(anonymous function) @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,plupload,json2,jquery-u…:4(anonymous function) @ admin.php?page=appointments:1164m.event.dispatch @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,plupload,json2,jquery-u…:3r.handle @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,plupload,json2,jquery-u…:3

  • Judah

    @adminMichael,

    I found the issue...

    In my appointments.php file I made the following modification (to solve a padding issue ) I followed the instructions in the other post and it solved the padding issue.

    After I made the changes the padding in the admin backend were applied, but I was not able to properly save updated appts and email the users.

    In started going through the changes and when I removed the

    `global $appointments ;
    $appointments = $app;`

    from my Appointments.php file (just removed those two lines and not all of the other code modifications) I was no longer having this issue.

    Specifically this is the code I am referring to:

    `Appointments + plugin file :
    appointments/appointments.php

    Before editing on line number 7129 :
    $app = $wpdb->get_row( $wpdb->prepare("SELECT * FROM {$this->app_table} WHERE ID=%d", $app_id) );
    After editing on line number 7129 :
    $app = $wpdb->get_row( $wpdb->prepare("SELECT * FROM {$this->app_table} WHERE ID=%d", $app_id) );
    global $appointments ;
    $appointments = $app;`

    I was able to (re)send the confirmation and get the green Changes Saved message. Unfortunately, my padding issue in the backend is a major problem.

    So now I have to either choose between not being able to updated my clients if their appointments change or not being able to properly update the appointment times because the padding is not being applied to the dropdown.

    What should I do? (I will be re-opening up the padding issue thread as that 'solution' is causing my issue)

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.