Updating Error in Wordpress 1.5.2

When I try to update from Wordpress 3.5.2 to 3.6, I get the following error(s):

"Warning: touch(): Unable to create file /tmp/wordpress-3.tmp because No such file or directory in /home/yaznetx1/public_html/wp-admin/includes/file.php on line 179

Warning: unlink(/tmp/wordpress-3.tmp): Operation not permitted in /home/yaznetx1/public_html/wp-admin/includes/file.php on line 503
Download failed.: Could not open handle for fopen() to /tmp/wordpress-3.tmp

Installation Failed"

How does one fix this? Any help is greatly appreciated..