Updating is suddenly broken on multiple sites for multiple plugins.

Updating is suddenly broken on multiple sites for multiple plugins of mine. Not sure why, but with even with Dashboard 4.4, any new updates for WPMUDEV plugins always say that the plugin is updated to latest version within WPMUDEV, but never are. Dunno why updates mysteriously stopped working or when, except it stopped sometime in January; maybe it has something to do with the newest version of WP that came out last month?

Highly descriptive error shows when updating from plugin page:

All other non-wpmudev plugins update perfectly fine. So wpmudev plugins must have a different way of updating (unfortunately?).

How can we fix this?

Thanks!

  • Predrag Dubajic
    • Support

    Hi Carmelo,

    Hope you're doing well.

    There are no known issues with the latest version of the WordPress so that shouldn't be an issue, this looks like your server is having issues communicating with ours.

    Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Best regards,
    Predrag

  • Carmelo
    • Site Builder, Child of Zeus

    Access granted. Thanks for checking it out.

    I disabled WordFence just in case that blocked plugin updates, but It didn't change anything. I can't seem update WPMUDEV plugins. Other plugins update just fine. This isn't the only site of mine that I have with this same issue.

  • Predrag Dubajic
    • Support

    Hi Carmelo,

    Are all of your sites having this issue or just specific ones?

    Are the all the troubling site hosted on the same server by any chance?
    And also, if there are couple of troubling sites on the same server, is any of them running an outdated version of WPMU DEV Dashboard?

    Information on your site seems correct, HTTP requests are returning OK and your site is not blacklisted on our end, so above info should help with determining the cause of this.

    Can you also try going to WPMU DEV panel in your WP admin, log out from WPMU DEV account and then log back in and see if the update is working after that?

    Best regards,
    Predrag

  • Carmelo
    • Site Builder, Child of Zeus

    Dashboard is updated as much as can be (4.4), I am the admin of the cpanel server and haven't changed any server configurations since or before this happened. Happens on any site that I have that has wpmudev plugins that have updates available it seems. Also, only wpmudev plugins are affected, not others, which update fine- so regardless of any server changes, I would think this really shouldn't be happening..

    I have logged off wpmudev and logged back on and still the same issue occurs.

    I suppose next I can just try replacing plugins entirely by downloading them from wpmudev and uploading them via ftp to replace old files.

  • Predrag Dubajic
    • Support

    Hi Carmelo,

    You can always update plugins manually, but no one wants to do that, it's a lengthy task and we will like to get to bottom of this for you :slight_smile:

    Do you have a staging site with this issue where we could dig into this further?
    Could you provide us with FTP or cPanel access so we can investigate it further?
    You can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Predrag Dubajic"
    - Site login url
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.