Updating NELO theme from an older version (2.1)

I used to have a WPMU membership a few years ago and used the NELO theme for one of my websites back then. I would like to update it, but was wondering what I should know before doing so.

I have also yet to update the WP version to 3.5 from 3.2.1 because of possible issues that I may have with the theme.

Please advise! Thanks in advance!