Upfront 1.2 Installation failed

Hello,

I want to change the layout for the default 2012 theme of wordpress, so I believed I could install just Upfront 1.2 without theme to modify the 2012 theme. Now, if I install Upfront it occurs an error saying that the installation for upfront failed :slight_frown: Any suggestion? I don't want to install any other themes because of conflicts with all my plugins.

ps: I selected WPMU DEV Dashboard in the ticket form because it didn't have any suitable topic regarding my problem.

  • Adam Czajczyk

    Hello Roger,

    I hope you're well today and thank you for your question!

    Our Upfront framework (theme) is a great tool to visually create a layout but it's an entire "ecosystem" that requires one of the "starter" themes to work. It cannot be activated alone and won't work with any other theme than one of its child themes that you will find here (click on "see starter themes"):

    https://premium.wpmudev.org/projects/category/themes/

    Therefore, you may want to install one of these themes and build upon it. Upfront will be automatically activated once you enable one of that themes.

    That said, you may notice that these are "ready to use themes. You may fully customize them and build upon them of course. Our developers are also preparing a "blank" theme along with a "Theme builder" feature that will together let you build your own "starter theme" from scratch and then export it to be used on any other site with Upfront installed the same way as our "starter themes" can be used. I'm not able to give you any ETA on this though.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.