Upfront and Fixer - Unable to save changes!

Hi,

I am unable to save any changes made to Fixer theme. When i attempt to save the changes I get a message

There has been an error saving your changes
.

Thanks for your help.

  • Sajid

    Hi Mun,
    Hope you are doing good today :slight_smile:

    This is the issue happening on NGINX servers, mostly. Please try one of below mentioned methods to fix this issue and also I am including the explanation of why its happening by the Developer.

    The issue with saving Fixer's homepage using the Upfront editor happens on sites with NGINX servers caused by the complex size of Fixer homepage. This is due to how Upfront 1.0 saves the layout and is considered as "too large" by NGINX's default settings.
    Changing the way Upfront saves the layout would require significant work (we're talking the level of a major release), therefore we couldn't achieve such a change in the near future.
    Meanwhile, there are possible temporary solutions for this:
    #1: If you can adjust the NGNIX configuration, you'd want to try increasing the value for the "client_max_body_size" variable.
    #2: Increase the values for "upload_max_filesize" and "post_max_size", either by altering your server's PHP configuration, or setting up a custom php.ini in your site's folder, in the event that altering the main PHP configuration is not an option.
    As far as we could test, Apache servers are not affected by this.

    Please try that and let me know how it goes :slight_smile:
    Cheers, Sajid

  • Mun

    Hi Saijd,

    I have upgraded php version to 5.6 and update the php.ini to:

    Maximum size of POST data that PHP will accept.
    ; http://php.net/post-max-size
    post_max_size =50M
    ; Maximum allowed size for uploaded files.
    ; http://php.net/upload-max-filesize
    upload_max_filesize = 50M

    ; Maximum number of files that can be uploaded via a single request
    max_file_uploads = 50

    And still CANT save any changes!!

    Cheers

  • Madhusudan

    Hello Mun ,

    I would like to do further test to find out the solution. If you do, could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Madhusudan Pokharel
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanking you,
    Madhsudan

  • Madhusudan

    Hello TimelordEU ,
    This could happen when server limit exists for security and efficiency’s sake preventing users from uploading huge files. You can fix it by increasing the Maximum Upload Size.

    1. Increasing the Upload Size Limit In a Multisite Install
    For a multisite installation you can control the upload limit for your sites from Settings -> Network Settings, and input the higher value. However, if the server is set to a limit of 3MB and you set 10,000 Kb (10MB) in the network settings it won't just work.

    2. Asking Your Host to increase limit:
    In the case the host don't let you increase this yourself, it can be increased simply by contacting your host and asking them to increase the limit for you.

    3. Modifying the value yourself:
    Try increasing the following values in php.ini, for example:

    upload_max_filesize = 64M
    post_max_size = 64M
    max_execution_time = 300

    There are other ways to modify server's settings. Please refer to the tutorial below :
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Note that on some servers you could instantly see the effect and if you can't the server might be caching the files.

    I hope this helps to resolve your issue, and if it doesn't let us know.

    Thanking you,
    Madhusudan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.