Upfront background video Mute option is not working

The video in the home in Upfront builder is muted but the video still has sound. Plugin conflict test suggests a conflict with Slider WD plugin. Any tip to solve this? I need this plugin 100%

  • juan

    I create this js to solve it (I don't know if is the best way, but seems that solve it). The problem is that in upfront doesn't work...the iframe route doesn't change. Any tip??

    Here you can test it testJS

    The JS:

    <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>

    <iframe width="10000" height="5625" src="https://www.youtube.com/embed/4NHpOYnylBg?feature=oembed&&controls=0&showinfo=0&rel=0&wmode=transparent&html5=1&modestbranding=1&loop=1&enablejsapi=1&autoplay=1&enablejsapi=1" id="bg_video_1" frameborder="0" allowfullscreen=""
    style="position: absolute; width: 1349px; height: 755px; top: -59px; left: 0px;"></iframe>

    <script>
    $( document ).ready(function() {
    var newsrc= document.getElementById("bg_video_1").src+'&mute=1';
    document.getElementById("bg_video_1").src = newsrc;
    });
    </script>

  • viobru

    Hi, Juan,

    Hope you're having a great day :slight_smile:

    Sorry for such a long delay in response seems that somehow we were not notified when you posted your reply, I do apologize for that. Also, please note that bumping tickets causes them to go back in the queue, because we respond them in order of oldest to newest (Ref. Support Ticket Etiquette: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-1)

    Many thanks for sharing the code snippet with us!

    As my teammate Huberson mentioned, our Second Line Support was informed about this, so I’ll transfer this code snippet to them and you’ll be notified if they can set a solution for this.

    Kind regards,

    Violeta

  • Lindeni Mahlalela

    Hello juan

    I hope you are doing great today. Thank you for contacting us regarding to this issue. I am really sorry for the delayed response from our side.

    I have had a look at your website today, I have installed the Slider WD plugin on a test website and found that the audio plays when editing the page using upfront. But when the page is rendered for a visiting user the option to mute the audio is honored. The option to mute the audio was intended to be applied when the page is viewed in the front end.

    I checked on my website and your websites and confirm that the audio does not play when the page is viewed as a user. If it helps, there is an option to load the scripts of the Slider WD plugin only when required instead of loading it on all pages. This can be found in "Slider WD > Global Options" menu:

    This will be very useful because the scripts will not cause any conflicts if they are not loaded on the page being loaded. So if you have the video backgrounds on the home page and you don't have any slider on that page then this will be a useful option for you.

    If this is not exactly the issue you were reporting and or you wanted the mute option to mute when editing the page then let us know and we will be happy to help.

    Another issue I found that might cause an issue is that on the web console there is this error:
    fullPage: Fullpage.js can only be initialized once and you are doing it multiple times!

    The issue is that JavaScript errors can cause serious problems on a website that heavily relies on JavaScript, this issue originates from the script in "FullPage Scroll JS" added using the "Custom CSS & JS" plugin. You should give it a thought and try to fix it.

    I hope this helps, please let us know if you have any questions or concerns and we will be more than happy to help.

    Have a nice day.
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.