Upfront broken on homepage

We're using your excellent Upfront theme extension on a client's site, and when I try to edit the homepage layout using Upfront, the Upfront sidebar doesn't load and the rest of the interface seems distorted (see attached Trienawear homepage.png). Upfront seems to load properly on the inside pages, but not the homepage. There's also been an issue with certain elements changing size and/ or color when invoking Upfront on the homepage (see attached before & after-upfront-runs.png). Any assistance you can offer would be greatly appreciated.

  • Adam Czajczyk
    • Support Gorilla

    Hello Joseph,

    I hope you're well today and thank you for your question!

    Are you getting any error messages when trying to enable Upfront editor on homepage? Let me know please if there are any.

    I'd also like to take a closer look at your site and run some more tests on it. Would you mind granting me a support access to it? You may do this using our WPMU DEV Dashboard plugin and here's a handy guide for this:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Joseph,

    Thank you for granting an access.

    I checked your site and I can see that your WordPress is set to use only 40M of 256M memory limit available for PHP scripts. In fact it's the most common reason for issues like this so let's please start with increasing that limit.

    In order to achieve it please add following line to your site's "wp-config.php" file:

    define('WP_MEMORY_LIMIT','256M');

    The line should be placed above the "/* That's all, stop editing..." line. After you add it there please clear your browser's cache and also go to "Upfront -> General" page in your site's dashboard and click on "Reset Upfront Cache" button.

    Once this is done please check Upfront on homepage again and let me know if this helped.

    web Services,

    Please try the same steps. In case it doesn't work for you please start a separate thread of your own on our Support Forum.

    Best regards,
    Adam

  • Joseph
    • WPMU DEV Initiate

    Thanks, Adam. I followed your advice and added
    define('WP_MEMORY_LIMIT','256M');
    to my config file, but I'm still getting the same problem when clicking Upfront on the homepage. Like I said before, the inside pages are loading Upfront fine; the problem still persists on the homepage. I'll grant you support access once again for a second look. Could the problem have something to do with the number of elements on the homepage?

  • Dimitris
    • Support Star

    Hey there Joseph,

    I hope you're doing well today and don't mind skipping in! :slight_smile:
    There's some things you could do in order to provide us with better insights on this.

    Thanks, Adam. I followed your advice and added
    define('WP_MEMORY_LIMIT','256M');
    to my config file, but I'm still getting the same problem when clicking Upfront on the homepage.

    First af all, would you mind contacting you hosting provider in order to confirm that this definition doesn't get overwritten by the server? Just to make things clearer. :wink:

    Then, some host providers (Siteground had been mentioned in older threads) may block Upfront's scripts from loading, even though I didn't manage to reproduce any script error in dev tools. Would you please deactivate mod_security filter by putting the following line to the very beginning of .htaccess file:

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    If this makes no difference, please revert .htaccess file and proceed with a plugin conflict test. You can find a detailed flow chart in https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/.

    Again, if this continues, you can please enable debug log in your wp-config.php by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Go to homepage and activate Upfront editor. This should create the debug.log file in your wp-content folder that could tell us what is going on. Save it as .txt file and attach it here so we can check it out.

    Waiting for your response,
    Dimitris :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.