upfront builder basic

i want to make 3 themes in upfront builder
1st theme its open automatically upfront builder and there shows in left menu theme layout option
but in other its not open automatically themes there are not show layout option how to fix it?

  • Predrag Dubajic
    • Support

    Hey Crownempire,

    Hope you're doing well today :slight_smile:

    This thread was started in Members forum but since it's about one of our products I've moved it to our Support section since Members forum is more of a general chat section and it doesn't guarantee staff answer.

    Would you mind allowing support access and tell us what themes are not showing layout optionso we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Crownempire,

    Thanks for granting access, it looks like the theme folder names are overriding with an existing pages in your first theme or a media file etc. and that causes Builder not to load properly.

    Can you try creating new theme with a more unique name because when I created new theme on your site it loaded properly.
    Let us know how it goes after that.

    P.S. Thanks for the positive vote, this actually notified me about your thread I saw that support access was granted.
    In future please make sure to respond in the thread so we know that the access is granted, messages left in support field inside WPMU DEV > Support panel are not sent to us and are there as an additional note once we access the site.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Crownempire,

    Child themes created via Builder are saved in your themes folder as regular WP themes.
    You can go to Appearance > Themes panel in your WP admin and in there you will see your themes, click on Theme Details for desired theme and in popup window there will be Delete link in bottom right corner.

    Best regards,
    Predrag

  • Dimitris
    • Support Star

    Hey there Crownempire,

    hope you're doing good and don't mind chiming in! :slight_smile:

    I just accessed your website after you kindly granted support access for us but I can spot three different themes. Could you please point to us which theme gives you troubles and which region specifically (if there's one)? A screenshot with the region would be perfect!

    Warm regards,
    Dimitris

  • Adam Czajczyk
    • Support Gorilla

    Hello Crownempire!

    I checked your site and I'd like to make sure that we are on the same side here first.

    I checked that region's CSS in Upfront Builder and it doesn't seem to have any custom css added. I have then checked it using Upfront (Upfront editor) and I can see some CSS there, furthermore - that CSS is present on the site. You can confirm that by using browser's "Inspect Tool" element while accessing the site as logged out user.

    I suppose then that the issue here might be that the image is not being displayed on front-end while not in Upfront/Upfront Builder mode, is that correct?

    The "Behind the scenes..." image is reported by the browser as "failed to load". I downloaded the theme and installed it on my site and the image is displaying fine there (the same way as in Upfront Builder on your end) but on your site it does not. Could you please give a simple trick a try then?:

    - switch to your other custom theme
    - edit your "second theme" in Upfront Builder
    - change that image to some other image (it can actually be a copy of that original image, just under different file name)
    - save the theme (not setting it as active) and leave Upfront Builder
    - go to "Upfront -> General" page and Clean Upfront Cache
    - activate the theme and see if the image shows up.

    Let me know about result please.

    Kind regards,
    Adam

  • Crownempire
    • WPMU DEV Initiate

    I followed your instructions like I saved changes without activating theme. After that i closed upfront and cleared cache and then activated theme and logged out from wordpress. Then i checked again but nothing changed.

    The main problem is changes are saving in admin panel but when i check in preview the changes are not showing.Please fix the issue asap.

  • Dimitris
    • Support Star

    Hey there Crownempire,

    hope you're doing good and don't mind chiming in!

    I just went ahead and inspected your theme and noticed that the actual image wasn't added via UF Builder, which is used to build the actual theme structure (folders and files) and the default theme content, but via UF Editor (like when you click on the "Upfront" link in the top admin bar that leads you to example.com/?editmode=true) which should be used to set the site specific settings of theme as these settings are being saved in database tables instead of theme files (thus and site-specific).

    Having said that, I activated UF Editor and I was able to reset the image on the top right element and everything seems fine now, unless I'm missing something else here so please do correct me and further advise! :slight_smile:

    Take care,
    Dimitris

    PS. You can find all UF related documentation pages here https://premium.wpmudev.org/docs/upfront-and-themes/

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.