Upfront builder doesn't load under http

Since today I successfully enabled SSL (https). This works fine in most cases. When I am in the WordPress backend and click under Upfront on "edit theme", the browser points me to a loading screen of Upfront. This loading screen doesn’t disappear. I did a little troubleshooting and I found out that this is because the Upfront editor is loading via http. When I manually reload the editor via https all works great.

My question: How can I prevent the editor to be load via http? All the other functions in Wordpress loads directly via https. So I think (maybe I am missing something) I activate https correctly. The only thing I can imagine is that I didn’t replace the http urls in the database. I didn’t do this right now to prevent further issues.

  • Adam Czajczyk

    Hello Raf,

    I hope you're well today and thank you for your question!

    I'm not quite sure how did you set up "force https" for your site but I assume that's on CloudFlare side and it's a redirect.

    When visited via HTTP connection your site site returns "302" HTTP status which is a "Moved temporarily". It's one of the common HTTP redirects. The consequences are that some parts of your site (Upfront but also some other plugins) may not "know" that the HTTPS should be used.

    Why that happens?

    A lot of resources in WordPress (that's not only an Upfront issue) is fetched by the explicit URL. These URLs are usually fetched from WP settings using core WP functions. Such a function will return the "http://" protocol because this is what's set in WP options and sits in a database.

    As a result Upfront (and some other themes) will attempt to fetch aforementioned resources via insecure "http://" protocol and the browser - which expects secured https:// connection - will block them due to the security reasons.

    To fix it, you may want to try this plugin:

    https://wordpress.org/plugins/ssl-insecure-content-fixer/

    You may have to experiment a bit with its settings but there's a chance that it will help (it attempts to "internally rewrite" the URLs of resources to https://). However, if it doesn't work, the solution would be to update WP URL's (that's actually suggested way to run WP over HTTPS) to the "https://" prefix for the site that's supposed to run over HTTPS and is using Upfront.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.