Upfront Builder Errors

Hello,

I am having some issues with Upfront Builder where I keep getting errors and time outs. I will make some changes and save, but it simply does not work. The saving screen overlay will popup, but doesn't go away and doesn't save. If I refresh the page, changes are lost. Some changes work and save, but I am consistently having problems and haven't been able to identify the issue.

This is a fresh install, on development sub-domain, and in a sub directory. I have entered some htaccess to mask the sub directory and not sure if it is an issue, but I have pasted that into the support access quick message area. I did not do this on the main www site, but also have the issue there. I also have debugging enabled with display. Please review and let me know if you have any questions.

Thanks, as always, your help is appreciated.
Michael

  • Rupok

    Hi Michael,

    I am having some issues with Upfront Builder where I keep getting errors and time outs. I will make some changes and save, but it simply does not work

    Thanks for granting Support Access. I logged in and tried to edit the Homepage layout in Upfront Builder in you site, but I could not face those errors you mentioned. I can see some notices as you have debug display enable, but changes are saving fine without any issue and staying. I've created a screencast showing this: http://take.ms/fkyfX

    The saving screen overlay will popup, but doesn't go away and doesn't save. If I refresh the page, changes are lost

    I've also shown in the screencast that changes are saved without any issue, and saved every time I try. So I'm not sure why this is happening on your browser.

    As a quick troubleshooting step, can you please try clearing cache and cookies from another browser? Can you try from a different browser? Can you try from a different computer or network? Please let us know if you can regenerate the issue in every scenario.

    And please let us know if you have any confirmed step which results in those errors you mentioned. I'll do that and will try to regenerate the issue on your site. We will investigate further as soon as we can regenerate this on your site.

    Please let us know all these details. I'm looking forward to hearing from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Mtwo

    Rupok,

    Thank you for the quick response. I did check other browsers and experienced the same issue. Even with Firefox that has never been to the site before. I also checked another computer and had the same issues. I cleared cache and related, restarted computers, and had the same issue. The computers did restart overnight, windoze updates, and when I loaded the site today, everything worked fine. Strange, as even incognito had this issue. I though incognito did not use cache, cookies and related.

    I made some changes today and things seamed like they were working, but now my changes are not showing through onto the public facing site. For example, the header is not the current header as viewed within builder.

    I deleted the header entirely and re-created it. I picked default menus in case the ubermenu was conflicting and it is still not working. The logo image does not display and that looks to be because of the sub-directory install and related htaccess. How can I correct this?

    As to the menu, is this also because of htaccess as styles are not transferring through. I have tried both default menus and ubermenu, but both have the same issue; they display fine within builder, but when viewed on public site, do not work.

    I deleted and tried again, but the social menu on the left of the logo simply does not display on public side, so something is not working correctly. I added both a menu and an uber menu and both do not display on the front end. Any ideas as to what is causing this and how to correct. Please let me know.

    Thanks,
    Michael

  • Mtwo

    Hello,

    I moved WP core files back to the root directory and deleted the related htaccess. Still having issues, I also added Upfront debugging via wp-config and reset the Upfront cache.
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    I was still having issues, so I started fresh, creating a new theme via builder. I have thoroughly cleared my cache, flushed DNS, and started fresh. I began creating the theme again, but again ran into issues saving. The console of my browsers inspector consistently shows me "Failed to load resource: net::ERR_CONNECTION_TIMED_OUT" errors. I disabled the firewall on my modem level and things started working again. I still am getting the occasional timed out error message and failing to save, but things are working better.

    Not sure how to troubleshoot this further, so I am frequently saving the theme. I just saved the theme again and it is stuck "Exporting layout: archive". I have an error in the console for
    wp-admin/admin-ajax.php Failed to load resource: net::ERR_CONNECTION_TIMED_OUT. What could be causing this?

    Michael

  • Mtwo

    Hello,

    After a bunch of troubleshooting I have come to identify that there was an issue with my ISP. My Internet lines were damaged and causing dropped packets. I didn't have these issues on my own server, but with the server of this site being much further away, the dropped packets made a difference. Had support out and installed new lines to the pole and local line tech also changed some lines in my local area. Problem seams to be gone now as I have not had any error connection timed out issues.

    Thanks,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.