Upfront Builder is trying to use a subdomain?

Hey guys,

I'm trying to do some development of some custom upfront themes so I'm taking builder for a walk.

When I click "Edit in Builder" I get redirected to a subdomain off my main domain which is matches the "theme directory" value. This is true whether I create a new theme or try to edit an existing one.

My first attempt was using a local dev env using local by flywheel (local.getflywheel.com) but I also setup a public site for this (themes.littlefyr.com). I've tried this using both the Brave and Chrome browsers with the same effect.

  • Predrag Dubajic

    Hey Adam,

    Hope you're doing well today :slight_smile:

    I tried replicating this on my installation but I was unable to do so.

    I've try to edit one of the existing themes in Builder on main site in my network and the URL was correct, it shows like this domain.com/create_new/uf-fixer

    Would you mind allowing support access so we can have a closer look at this on your end?
    To enable support access you can follow this guide here:

    Please respond in this thread once access is granted.

    Best regards,

  • Predrag Dubajic

    Hi Adam,

    I'm starting to think that there is either magic or gremlins involved :slight_smile:

    On a serious note, I had a look at your site and it's really strange that this happens, it's clean installation and nothing wrong shows in console that could tell us what's going on.

    I also tried changing permalink settings to see if something there could be causing it but that was not it.

    I would like to check out your .htaccess and wp-config.php files if you can post the content here, but first please remove any sensitive data from wp-config.php, like DB login information.
    Please use code tag when adding their content so they get formatted properly.

    Best regards,

  • Adam

    ok here:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress


     * The base configurations of the WordPress.
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {obito http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     * @package WordPress
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'snipped');
    /** MySQL database username */
    define('DB_USER', 'snipped');
    /** MySQL database password */
    define('DB_PASSWORD', 'snipped');
    /** MySQL hostname */
    define('DB_HOST', 'snipped.com');
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
     * Authentication Unique Keys and Salts.
     * Change these to different unique phrases!
     * You can generate these using the {obito https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     * @since 2.6.0
    define('AUTH_KEY',         'snipped');
    define('SECURE_AUTH_KEY',  'snipped');
    define('LOGGED_IN_KEY',    'snipped');
    define('NONCE_KEY',        'snipped');
    define('AUTH_SALT',        'snipped');
    define('SECURE_AUTH_SALT', 'snipped');
    define('LOGGED_IN_SALT',   'snipped');
    define('NONCE_SALT',       'snipped');
     * WordPress Database Table prefix.
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
    $table_prefix  = 'wp_tgc2pk_';
     * Limits total Post Revisions saved per Post/Page.
     * Change or comment this line out if you would like to increase or remove the limit.
    define('WP_POST_REVISIONS',  10);
     * WordPress Localized Language, defaults to English.
     * Change this to localize WordPress. A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
     * language support.
    define('WPLANG', '');
     * For developers: WordPress debugging mode.
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
    define('WP_DEBUG', false);
    /* That's all, stop editing! Happy blogging. */
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
            define('ABSPATH', dirname(__FILE__) . '/');
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    I hate putting security things in here so I replaced anything that looks security related with snipped

  • Predrag Dubajic

    Hi Adam,

    I just did some additional testing when using flywheel and I was able to replicate the issue when using themes.domain.com, it seems like the issue is happening when THEMES is set as start of your domain.

    I'm pretty sure that this is the cause since your live site starts with THEMES as well, but just to double check can you tell me if your local installation domain also started with THEMES?

    Best regards,