Upfront Builder not working


I’ve just turned my laptop off after spending a few frustrating hours looking around and installing plugins when I realised the reason I cancelled before. The Upfront Builder doesn’t work. I’ve tried the Fixer theme and the Scribe theme, exactly the same thing happens. I even tried creating a new theme and that doesn’t work at all. I’ve uninstalled plugins and reinstalled them but still the same thing.

Pressing Upfront on the homepage seems to break the page, maybe something to do with the stylesheet. It doesn’t load the builder at all. Then when I click on another part of the site (eg the dashboard) it attempts to load the Builder but usually hangs on 19% loading. I’ve managed to get access to it once, somehow, but it still didn’t function correctly.

Any suggestions what could be causing it?

  • Adam Czajczyk
    • Support Gorilla

    Hello Jamie,

    I hope yo’re well today and thank you for your question!

    Three most common reasons for such issues are:

    1. insufficient PHP/WP memory limit

    2. too strict “mod_security” Apache module settings on server

    3. too low “post_max_size” PHP option value

    There may be other reasons I think but these three are the most common. I’d therefore start with checking WP memory limit and if it’s (as it often happens) set to 40M or 64M I’d raise it to 256M. You can check that limit by going to the “WPMU DEV -> Support” page in your site’s dashboard (if you have WPMU DEV Dashboard plugin installed) and then clicking on “System Info” button and switching to the “WordPress tab” looking for “WP_MEMORY_LIMIT” value (not to be confused with “WP_MAX_MEMORY_LIMIT”:wink:.

    If that value is low, you may raise it by adding following line to the “wp-config.php” file of the site:


    above the “/* That’s all, stop editing… */” line.

    If that doesn’t help, the “mod_security” should be checked. Often you can find that in cPanel (or the server control panel that you got access to) and you may be able to switch it off for the domain where Upfront is used. If there’s no information (or option to switch it off) about “mod_security”, please get in touch with your host and ask them if they could switch it for you.

    If none of above is the case or just doesn’t help, I would want to take a closer look at the site so please grant me a support access to it as described in this article (and let me know here when it’s enabled):


    Best regards,


  • Jamie
    • Flash Drive

    Hi Adam,

    Thanks for your reply.

    I changed the memory limit to 256 as instructed, but for some reason it caused the whole website and admin to stop responding completely. I restored the previous wp-config which let me back on, then I tried putting the updated wp-config in again and everything seemed to work, including the Upfront Builder. I had the ‘Scribe’ theme installed at the time, but I wanted to use the ‘Fixer’ theme instead, so I installed it and activated. As soon as I tried the Upfront Builder again, the same problems happened as before. I deleted Fixer and re-activated Scribe (thinking there was a problem with the Fixer theme) but Upfront Builder still didn’t work.

    I don’t have access to the mod_security option, so I’ve sent a support ticket to my hosting. I don’t know how long they’ll take to get back to me, so I’ve granted support access if you or somebody wanted to take a look around instead.

    Kind regards,


  • Predrag Dubajic
    • Support

    Hi Jamie,

    Can you try adding this line of code inside your wp-config.php above /* That’s all, stop editing! Happy blogging. */ line:

    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    If that doesn’t help can you ask your host to check server logs and see if there’s anything blocking AJAX requests?

    Best regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.