Upfront Builder - Panino Theme not functioning

Good morning all !

I'm having some trouble using upfront with the Panino theme:

After installing Upfront for the fitst time, it wouldn't go behind the 'loading screen'. I uninstalled it then, uninstalled the themes, and reinstalled Upfront. From then it works.

But now the Panino theme seems to be corrupt: although it is loading, the navbar for example doesn't stick to the top of the page, some css is missing, ...

My question is: how do I completely remove the Panino theme and reinstall it 'out of the box'?

I already reinstalled it but then it seems to get it out of the cache or something: I only changed the text in the yellow circle, and even after a full 'remove' and reinstall, the text is still changed and the theme is still corrupt.

Thanks all for your help !!

24

  • Dimitris

    Hey there Michael,

    hope you're doing good and don't mind chiming in! :slight_smile:

    Could you please try to go to Upfront -> User Restrictions, check that "Can See / Use Debug Controls" is set for your user role and hit "Save changes" even if it's set already?

    Then go to Upfront -> General and you should be able to see the commands that my colleague Predrag mentioned in his previous reply.

    previously to this post, I already uninstalled the Panino theme. I also cleared the caches but still, in WPMU Dashboard -> Themes, it shows the Panino theme and I could click activate:

    I was able to replicate this in my test installation, thanks pointing this out! :slight_smile:
    I'll ask some colleagues to double confirm that and move it forward to our dev team.

    Warm regards,
    Dimitris

  • Michael

    Hello dimitris & Predrag,

    first of all, thanks for all your help.

    This is what I did so far:

    1. I went to Upfront -> User Restrictions and everything was marked for my admin role. I clicked 'save changes' to make sure. Then I checked Upfront -> General and I the options described by Dimitris appeared. I could then click 'Reset Theme' and that worked, but not entirely: although the navbar now sticks to the top of the screen when scrolling, the css is still not working like it should.

    2. Yiha I found my first bug :wink: Glad I could help with the 'activate issue', Dimitris.

    Still, something weird is happening with this theme. And my WordPress is not that complicated, sort of a clean but updated install with a few plugins (mostly from WPMUDEV).

    If you want, I can 'open the site' for you so you can have a look yourself. No harm can be done there, it's all just testing. Let me know !

    kind regards,

    UPDATE: the css error described above is an issue with Hummingbird and probably has nothing to do with the theme itself:

    Failed to load resource: the server responded with a status of 404 (Not Found)
    (the_url_of_my_site_which_I_removed)/uploads/wp-hummingbird-cache/Noticons.svg#NoticonsFailed to load resource: the server responded with a status of 404 (Not Found)

  • Dimitris

    Hey there Michael,

    I'm really glad that you've manage to sort that out! :slight_smile:

    About the HummingBird Minification module, you will most probably have to fine tune this as it heavily depends on the themes and plugins that are activated. By fine tuning, I mean to exclude assets from minification and merge, as it may lead to broken CSS or JS code.

    What I'd propose as it seems to me that you're at the beginning with this, is to leave the minification module disabled until you have most of your site built. Then use Minification afterwards to scan the complete set of your styles and scripts and further fine tune them. If this gives you troubles at that point, feel free to create a new thread here https://premium.wpmudev.org/forums/#question :slight_smile:

    Warm regards,
    Dimitris