Upfront Builder PHP error causing white screen of death

I recently upgraded my server from PHP 5.5 to 7.0, updated some packages and rebooted the server. After the upgrade, the website is now stuck in a white screen of death.

I briefly turned on display debug to see the error. It is: Fatal error: Uncaught Error: Class 'DOMDocument' not found.

I did a bit of research prior to this and understand that Upfront is no longer being developed, I would just like to have this issue resolved and have the site functional again. Please help.

  • Dimitris

    Hello Salespro Domains,

    hope you're doing good today! :slight_smile:

    First of all, I tried to replicate this in a testing site of mine and running latest versions of Upfront and Upfront Builder. Even after updating PHP to version 7.2.8, everything is looking good in my end.
    So this should be:
    - either a conflict with some other plugin (I can see that error message is about widgets, so maybe a widget from another plugin is messing this up)
    - some custom code that you use in a widget

    As we don't have access to /wp-admin/, please enlighten me about the followings:
    1. Are you using a default Upfront theme? Have you made any changes on it using Upfront Builder? Or are you using a custom Upfront theme made via Builder? If so, which is the folder name in /wp-content/themes/?
    2. If any above case, have you also made site-specific changes in the theme, using Upfront editor? This would mean that there're site-specific settings stored in database, while Builder plugin stores everything, as default data, in file themes.

    Finally, I noticed that the SFTP credentials you've shared with us, doesn't have permissions to write in server, could you please do that for us? At least for the server path where the WP installation is.

    Finally, please do keep a full backup of all files and database, so we could safely proceed with any troubleshooting. This could include some plugin conflict test, so I need you having a backup in place, so if any settings got lost during the tests, you can have an easy way to revert. :slight_smile:

    Warm regards,
    Dimitris

  • Salespro Domains

    Hi Dimitris,

    I am using a custom made Upfront theme. It is under wp-content/themes/lgs/
    I am not using any widgets either. I do have a backup of the website available so, no worries there. I am not sure if I made site-specific changes.

    You should also already have access to the dashboard, I provided credentials in my live chat with the support agent. Please let me know if you need these credentials or if they were not provided to you.

    I've also given your SFTP credentials write access in the var/www folder now.

  • Dimitris

    Hey there Salespro Domains,

    appreciate the additional info. :slight_smile:

    I proceeded with a plugin conflict test and found out that it was the "Simple Social Icons" plugin that was causing that, via its widget that's placed in the footer.

    I've already tried an alternative, the Social Icons plugin and seems that works well, not through its widget though, but via the shortcode it provides. You just have to select a Text element in Upfront, instead of Widget, and insert the generated shortcode in there. Plugin is already installed and activated and you can find the settings page here:
    https://yourdomain.com/wp-admin/edit.php?post_type=social_icon

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.