Upfront Builder - Saving any changes not working anymore

I recently started having an issue with Upfront Builder whereby any changes i make to my theme cannot be saved. The attached export layout loading popup simply continues to loop and never saves.

I believe this has started since the latest update was released.

I have tried to export the theme (in Wp-Admin - Upfront - Builder Menu) to test on an older version of upfront but i get an error when trying to export "Oops, something seems to have gone wrong." I presume this is related to the saving error.

Steps already taken:

1) Disabled all themes except upfront.
2) Reset Upfront as well as Browser cache.
3) Update all plugins, etc to latest version.
4) Checked other threads and tried suggestions without any luck.

Any help would be much appreciated! I have granted support access.

  • Dimitris

    Hey there Sprenzy,

    hope you're good today and thanks for reaching us! :slight_smile:

    I just went ahead and inspected your site. Activating the Builder and hitting the "Save Theme" button exported the archive layout without any errors.
    Is this resolved? Or should I reproduce some steps to get the freezing status, please advise! :slight_smile:

    If this continues, another step that you should make is a plugin conflict test, especially if you installed or/and updated any recent ones. You can find a nice flow chart here to help you out (just scroll down a bit) https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Kind regards,
    Dimitris

  • Sprenzy

    Hi Dimitris,

    Thank you for the super fast reply!!

    I just tried on my side again and still get the loop. Would you mind trying to replicate exactly what i do?

    I go to the Upfront Builder and edit my theme in the builder, i then click on layouts and choose to edit an existing layout for Single Posts: single-post. From the draggable elements i drag an image above the "Sample Post" region. Choose any image from the gallery and then try to save the theme. The exporting layout popup comes up with the loading animation as per my previous attached file, but the theme never saves.

    I have already conducted a plugin conflict test, unfortunately to no avail.

    Regards,
    Alex

  • Milan

    Hello Alex,

    Hope you are well today and wont' mind me chiming here. :slight_smile:

    I did perform all the steps you explained in your last post and I am able to save theme with image without any issue. Please see this screenshot for confirmation.

    Have you tried on different browser ? If not, please do try and also test after clearing browser caches and cookies. :slight_smile:

    Best Regards,
    Milan

  • Adam Czajczyk

    Hello Alex!

    I checked your site and I can see that the Builder doesn't even load fully/properly. I'm not sure how complex the theme/themes are (I check with "Test" theme) but I noticed the "500 Internal Server Error" in a browser console.

    This error in case of WordPress is most often related to the too low memory amount assigned. I checked site's config and your instance of WP is running on 40M of RAM memory (out of all 256M made available on the server to PHP). This is something worth addressing first so please add following line to the "wp-config.php" file of your site:

    define('WP_MEMORY_LIMIT','256M');

    This line should be placed above the "/* That's all, stop editing! */" line and will let WP use more memory. In case of issues with Upfront and/or Upfront Builder like this - it usually helps so please give it a try and let me know about result.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Alex,

    Thank you for getting back to me!

    I checked the site again and it actually moved us a little bit forward, though still not enough :slight_smile: There's still the error that I mentioned previously but in addition another error came up in a browser console.

    So, I took a closer look then and noticed that you are using CloudFlare but there's no "CloudFlare integration". By "integration" I mean either a WP plugin or integration configured in Hummingbird. That usually shouldn't be an issue but I because of this I wasn't able to check CloudFlare settings and give the Builder a try with it disabled.

    I assume however, that you may have the Rocket Loader feature enabled in CloudFlare settings. Could you please login to your CF dashboard and check its settings? If the Rocket Loader is enabled, disable it and give Builder another try. This should help but in case it didn't, please try switching CF off temporarily (there's should be a CloudFlare "bypass" switch in CF dashboard for your domain) just to see if that changes things.

    Keep me updated please.

    Best regards,
    Adam

  • Sprenzy

    Hi Adam,

    Rocket loader was/is disabled and i have now set up CloudFlare in Hummingbird.

    I put the domain on pause in CloudFlare and this seems to have sorted the issue, the changes now save.

    I have also emailed my host provider asking about the 40mb ram usage, hopefully will get an answer soon.

    Do you mind logging in once more to check if you still get the error you got before? Thanks again for all your assistance!

    Regards,
    Alex

  • Dimitris

    Hey there Sprenzy,

    hope you're doing good today! :slight_smile:

    I just inspected your website on Builder with your test theme. Even though the export is going through successful, it seems that the 500 error that Adam noticed is still there upon Builder's first loading. As this may extend when using more elements and templates, could you please access your server through FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);
    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /*That’s it! Stop editing… */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Afterwards open the Builder once and a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. This may reveal to us more info on it's origin, even though it may still has to do with the lower memory so let's first wait for your hosting provider reply.

    Warm regards,
    Dimitris

  • Sprenzy

    Hi Dimitris,

    Please see attached file as requested.

    My hosting provider replied and said that there is nothing on their side restricting the website to use more than 40mb of ram. I was a bit skeptical :stuck_out_tongue_winking_eye: so i ran the exact same site locally on my PC (XAMPP) and ram usage was pretty much the same.

    For what it's worth, the error in upfront has returned but only seems to be when i try and load the page layout. When loading the single-page layout, upfront seems to freeze at 15% (attached Capture.png). This error is present on my hosting providers server as well as locally on my XAMPP install. Starting to think it is not a problem on the hosting side?

    Regards,
    Alex

  • Dimitris

    Hey Sprenzy,

    I just went ahead and accessed your website one more time.
    I can now see in
    /wp-admin/admin.php?page=wpmudev-support&view=system#tab-wordpress
    that the WP_MEMORY_LIMIT is set to 256MB.

    I was also capable to load the Single Page layout of your test theme via Builder and also save/export the child theme.

    Do you still confront issues with that? Could you please give it another spin?
    You may have to clear your caches before testing (involving your browser's one http://www.refreshyourcache.com/en/home/).
    Please advise! :slight_smile:

    Kind regards,
    Dimitris

  • Dimitris

    Hey there Sprenzy,

    hope you're having a beautiful day! :slight_smile:

    I put the domain on pause in CloudFlare and this seems to have sorted the issue, the changes now save.

    Did you re-enable CloudFlare and you aren't able to save changes in Builder?
    Please advise!

    Could you please try to deactivate all other plugins, keep your caches clear/deactivated/paused and check once more?
    You may have to clear your browser's cache also. Here's some tutorials for different devices and browser versions. http://www.refreshyourcache.com/en/home/

    My workaround for now was to edit each page individually with the UpFront page editor (not builder).

    Please keep in mind that Builder stores everything in files so you can have a UF child-theme which can be transferred in another installation.
    Changes made via UF Editor though, are being made for the specific site as they are being saved in database tables instead.

    Warm regards,
    Dimitris

    PS. If you still have enabled the debug log definitions in wp-config.php file, feel free to re-share with us the latest file. Download /wp-content/debug.log file, rename it to debug.txt and attach it here in your next reply.

  • Sprenzy

    Hi Dimitris,

    No, cloudflare is still on pause.

    Saving the homepage layout works perfectly, as soon as i go to the single-page layout then the layout does not even load, get's stuck at 15% as per attached (this is on the current activated "SandCo" theme).

    I have cleared browser cache as well as our UTM's cache. Disabled plugins, tried different computers as well as different internet connections. Have tried IE, FireFox, Chrome and Edge, also same problem.

    I have re attached the dubug file.

    Regards,
    Alex

  • Dimitris

    Hey there Sprenzy,

    thanks for the additional information, I was checking the other "test child theme" you have in place.
    I can see now the frozen state in my end too.
    Could you please raise a bit more your memory limits and test if this is getting resolved?
    Simply access your server via FTP, edit wp-config.php file and add the following lines right before the /* That's all, stop editing! Happy blogging. */ comment

    define( 'WP_MEMORY_LIMIT', '512M' );
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );

    Additionally, you should raise the total memory limit of PHP. For doing so, go to your /wp-admin folder and find a file called php.ini or php5.ini. If you don’t see it, create one and insert the following lines:
    memory_limit = 512M
    Reference: https://premium.wpmudev.org/blog/increase-memory-limit/
    As this may get overridden by your server setup though, it would be great if you could contact your hosting provider's support to ensure that this raise is indeed working.

    I look forward for your results on this!
    Warm regards,
    Dimitris

  • Dimitris

    Hey there Sprenzy,

    hope you're doing good today! :slight_smile:

    I have personally tested UF child-themes and UF Builder in a test server with PHP v.7 and I had no errors, so I wouldn't say that this could be an issue, on the contrary.

    Is this happening only with "single-page" layout? Is so, could you try to delete the layout file
    /wp-content/themes/YOUR_THEME_NAME/layouts/single-page.php
    and try to re-create it?

    Could you also re-grant us with support access as it seems that expired? It auto-expires as a measure of protection. Here's our guide on granting access to your website:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Warm regards,
    Dimitris

  • Dimitris

    Hey there Sprenzy,

    hope you're doing good today! :slight_smile:

    I'm glad that you managed to sort that out! It seems like some data in the previous template files were messing around.
    Do you recall which updates you were installed in UpFront and UpFront Builder since you started building this child-theme? I wonder if this was an issue due to any of these updates.. :thinking:

    Warm regards,
    Dimitris

  • Sprenzy

    Hi Dimitris,

    I am, hope you are to!

    If memory serves me correctly, it seems to be the update from the last version to the current version.

    I will let know if i ever run into this issue again.

    On a side note, increasing the WP memory limit really helped sort out a lot of small issues i was having while working with upfront (the error 500 for instance). Definitely recommend doing this!

    Another side note, PHP verison 7 has made a massive performance difference on my webserver, would also recommend!

    Thanks for all your help! :thumbsup:

    Regards,
    Alex

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.