Upfront Builder Working

Hello WPMUDEV, I was trying to replicate a site build I had created earlier with Visual Composer with your Upfront Builder, but I was having trouble.

First of all, when I try to save my page layout (Save Theme), I get the spinning wheel of death. As in, it never actually saves

In adding WooCommerce products, is that strictly through shortcodes or widgets? I don't see the option to add widget areas?

I would really like to use the builder, I just need to know I can easily add elements.

Thanks!
Luke

  • Luke
    • The Incredible Code Injector

    Ahh yes!

    Your first solution fixed my original issue:

    "Try to increase the memory allocated to PHP a bit more by editing wp-config.php file and insert the following line just above the /* That's all, stop editing! Happy blogging. */ comment"

    define('WP_MEMORY_LIMIT', '256M');

    Thank you!

    Lets say I wanted to add a featured product feed.
    Would I just add:

    [featured_products per_page="12" columns="4"]

    Or this there a more dynamic way of showing WooCommerce products with Upfront?

    Thanks for your input!
    Luke

  • Luke
    • The Incredible Code Injector

    For Demitris, concerning the Upfront Theme Builder. . .

    The builder was working for the individual pages, but not for the theme. Still the endless spinner. I ran a debug.log for you.

    Let me know how I can help,
    Luke

  • Denitsa
    • WordPress Warrior

    Hey there Luke,
    I hope you're well!

    I'm sorry, I'm a bit lost, is your only issue right now being the Builder not saving, or are there any other unresolved queries here?
    I took a peek at your debug.log, but, unfortunately, there doesn't seem to be anything clarifying that issue.

    Also, I have noticed that you probably need to put the whole .... define('WP_MEMORY_LIMIT',)..... before the /* That's all, stop editing! Happy blogging. */ line in your wp-config.php as it's firing in the debug log.

    To be able to give better advice, we might need to take a closer look into your install and make a few test. This can be done if you'd grant support access from the dashboard plugin via Dashboard - WPMU DEV -> Support -> Support Access -> Grant Access or by following this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please advise if I'm missing out anything, so that we could help get this resolved asap. Have a nice day.

    Cheers,
    Denitsa

  • Luke
    • The Incredible Code Injector

    Hi Denitsa, I apologize for the confusion.

    The issue is the Builder not saving. Not for pages or posts, but for the theme editor in
    WordPress Dashboard > Upfront > Builder > Edit in Builder (on Fixer theme).

    I think this is correct for the wp-config.php:

    Let me know if not, have a wonderful day,
    Luke

  • Denitsa
    • WordPress Warrior

    Hey there Luke,

    Thanks for clarifying things! However, I can see you don't have the Builder installed on test.lcarlhart.com, so I can't test. Do you still want to troubleshoot this?

    You might try resetting the theme and the Upfront cache, just please make sure you have a backup first!
    This can be done for the respective theme via Upfront -> General -> DEBUG OPTIONS under RESET UPFRONT CACHE and RESET THEME.

    Let me know how it goes!

    All the best,
    Denitsa

  • Luke
    • The Incredible Code Injector

    Hi Denitsa,
    I reactivated the Upfront builder and theme. Tried to edit and save the theme, but it's still giving me the endless spinning wheel. You should be able to test on it now.

    Thanks for your help!
    Luke

  • Luke
    • The Incredible Code Injector

    I dont know if you guys were trying to work on your builder, but I was working on a replication of another site, so I had to revoke your access.

    I will try my best to get another subdomain going to test your Upfront Builder on by the end of the day. I will send you all info for it.

    Thanks again,
    Luke

  • Denitsa
    • WordPress Warrior

    Hey there Luke,

    Yep, I was testing the Builder on your site. :slight_smile:

    It seems there's an issue with the mod_security module. I would recommend you to get in touch with your host, and ask them to disable mod_security for you or at least "whitelist" your domain.

    This module is blocking "admin-ajax.php" calls made by Upfront returning "406 not acceptable" server response. This is what's causing this issue and turning off "mod_security" or whitelisting the domain should solve the problem.

    Let me know if this works for you!

    Kind regards,
    Denitsa

  • Luke
    • The Incredible Code Injector

    Thanks Denitsa!

    I want so badly to build my own themes, but I am in the process of learning PHP and building themes in general.

    With your theme builder, I see great promise. I will try to get another site up with your builder soon. That way I can speak with my hosting company regarding the issues you found.

    Thanks for being so helpful :slight_smile:
    Luke

  • Denitsa
    • WordPress Warrior

    Hi Luke,

    Let us know as soon as you have spoken to your host regarding that, we'll be glad to jump in if any further assistance is required! :slight_smile:

    If things don't go smoothly, you can enable support access on your future new site and notify us asap.

    All the best,
    Denitsa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.