Upfront compatibility with WooCommerce @ v1.05

Hi Developers,

I was just wondering is the new Upfront v1+ themes are indeed compatible with Woocommerce?

I know marketpress is great and all but there is alot of non-USA payment gateways and delivery modules that only exist for woocommerce right now.

Many thanks!