Upfront contact form not working

I added Upfront contact form to my contact page. But looks like its doing nothing when I click the send button of contact form. How can I fix that?

  • Adam Czajczyk

    Hello Barnaby,

    I hope you're well and thank you for your question!

    I have checked your site and the issue here is that there was no recipient address specified in form's settings.

    It seems that you have added the form while designing the site in Upfront Builder. Upfront Builder is a theme builder and specific settings for some elements - that are stored normally in the database - need to be specified "per page".

    To fix that, please edit your site (the "conact me" page) in Upfront (editor, not Upfront Builder) - that's the "Upfront" link above "Builder" link in "Upfront" drop-down menu of admin toolbar - and then

    - scroll down to contact form
    - click on settings ("gear" icon) for Contact Form element
    - in the Upfront sliding panel on the left replace current "test@yourdomain.com" mail that I have put there for testing with a real address that you wish to receive e-mails to
    - click "Ok" and "Update" upfront settings.

    I have tested this on your site with "test" e-mail that you used to create test admin account and when checking from front-end that seems to be working fine now so if you adjust an e-mail address that should solve the issue.

    Best regards,
    Adam

  • Barnaby

    Adam you’re a genius! I must have put the email address into upfront builderabout 153 times! Thanks for this, putting the email address into upfront editor worked like a dream.
    As a feature request would it be possible to request the option to put an email address into upfront builder as a default, that could be edited if needed in editor. It would be good as maybe a support email address for the theme, maybe?
    Anyways, thanks again.

  • Adam Czajczyk

    Hi @barnaby1!

    I'm glad I could help :slight_smile:

    As a feature request would it be possible to request the option to put an email address into upfront builder as a default, that could be edited if needed in editor.

    I honestly don't think that would be easily possible. A setting like this is stored in the database and while Upfront Builder is a "theme builder" (not a "site/page builder") it actually keeps everything it creates in files.

    However, I do believe that a bit different option would be possible and that would probably also help here: I think the Contact Forum module could be modified in that way that if no address is defined it takes the main site e-mail address as a default one. I'll suggest it to the Upfront developers. I'm not able to promise you that change or give an ETA but I will advocate for this :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.