upfront display panle

H i looking for some help my where I edit main homepage with up front 1 image displays in correctly and the up front control panel does not appear on the home page to make edits Iam logged out of all pages while trying to perform this action can please advise
thanks
Terry

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR,
    Hope you are doing good today :slight_smile:

    Well, that seems to be a plugin conflict. I am saying this because I could not replicate the same on my own test site. So there might be something on your setup that is messing with Upfront.

    First, please make a plugin conflict test as described in our getting support manual (see the flowchart).

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

  • BEAR
    • Site Builder, Child of Zeus

    Hello Sajid
    Hope all is well

    I tried as you suggested disable the plug ins to the min it looks good but when you use upfont to edit it the layout changes without having the upfront control panel does not display at all on the screen

    Best Regards
    Terry

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR,
    Hope you are doing good today :slight_smile:

    Could you please share the screenshot of the issue ?

    Also, please enable support staff access so I could take a closer look. To grant access go to WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Best Regards,
    Sajid

    • BEAR
      • Site Builder, Child of Zeus

      Hello Sajid
      Hope all is well
      I have included a screen shot this shot is in edit mode upfront,all is good but soon as use upfront this is a screenshot of it the control panel will not display upfront works on everything else BUT NOT ON MAIN PAGE you help would great value

      Best[image pos="0"] Regards

      Terry Berichon

  • BEAR
    • Site Builder, Child of Zeus

    Hello Sajid
    Hope all is well
    I have included a screen shot this shot is in edit mode upfront,all is good but soon as use upfront this is a screenshot of it the control panel will not display upfront works on everything else BUT NOT ON MAIN PAGE you help would great value

  • Nastia
    • Support Rock Star

    Hello BEAR

    Thank you so much for the screenshot.

    Although, without seeing a site up close it is hard to troubleshoot further. Do you have any custom CSS added to elements?

    As Sajid suggested, please grant access from WPMU DEV > Support so I can have a closer look at the issue?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know when you do!

    Kind regards,
    Nastia

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR,
    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. I could see this issue on your site now.

    Did you deactivated all plugins at once and then tried to edit with Upfront editor again ?

    Also, am I allowed to do a full plugin conflict test on your site ? (Since its your live site so I need your permission to do this).

    If yes, then please send in FTP details too. This way I would be able to make conflict test easily and also can restore site if something goes wrong.

    You can send the requested details via our secure contact form in following format (no need to include WordPress admin details if you keep the support staff access open).

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference

    Make sure you select "I have a different question" from dropdown as seen in attached screenshot so it get assigned to me and sent privately (otherwise it will posted in public form - so its important):

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR,
    Hope you are doing good today :slight_smile:

    Thanks for sending in the FTP and WordPress admin details. But these did not worked for me. Both passwords are incorrect (see screenshot of admin).

    We can use support staff access for WP Dashboard but still need FTP details to find out any error messages in error logs.

    Could you please double check the FTP details and send me again in the response of email you received from Mike Davis ?

    Best Regards,
    Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR,
    Hope you are doing good today :slight_smile:

    Thanks for sending the new credentials. WordPress logins worked this time but FTP credentials are still not working for me.

    However, I noticed that you are using older version of Upfront and Fixer theme. Please update these to latest version and then check again.

    If still don't work then please send working FTP details so I could further investigate this issue.

    Best Regards,
    Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR,

    Hope you are doing good today )

    I got the credentials again, but these are same that I have already. Does not work :slight_frown:

    Please try to delete the existing upfront theme (parent theme), install again and then check if it solve the problem.

    You can download the parent Upfront theme from any child theme project page. For example go to sprit project page and click on Upfront 1.6.1 link.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR :slight_smile:

    I am posting a reply here so we know the background instead of this thread:
    https://premium.wpmudev.org/forums/topic/does-upfront-auto#post-1189025

    I received the credentials once again that I have already. Me and my colleague Nastia tried as FTP and SFTP on FileZilla but does not work at all.

    As FTP, we are getting the authentication error as follow:
    Command: USER F137904
    Response: 331 Password required for F137904
    Command: PASS ************
    Response: 530 Login incorrect.
    Error: Critical error: Could not connect to server

    And this is what we get while trying to connect as SFTP:
    Command: open "F137904@202.59.111.200" 22
    Error: Connection timed out after 20 seconds of inactivity
    Error: Could not connect to server

    Sajid has looked at it but saying he can not login to check .BUT it works for me!!
    now Sajid is saying Please try to delete the existing upfront theme (parent theme), install again and then check if it solve the problem.

    I have posted the steps in your other thread and I am also quoting those lines over here too:

    Upfront parent theme does not get updated automatically. You have to update it yourself from WPMU DEV -> Updates.

    I know you are following my response in your other thread. So, incase you don't see the updates notice for Upfront then you need to do it manually via FTP or FileManager of cPanel.

    1. Take backup of your site including the Upfront theme.

    2. Now, go to wp-content/themes via FTP program like FileZilla (its free) or FileManager of cPanel and delete upfront folder.

    3. Now, download the fresh copy of Upfront parent theme. You can have download link to Upfront parent theme with every Upfront Child theme.

    For example, go to Fixer theme project page and click on Upfront 1.6.1 link to download the parent (see screenshot).

    See screenshot here:
    https://monosnap.com/file/Zhs4t7OK1HbPo37wuIi5TK4DGLi2f3

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • BEAR
    • Site Builder, Child of Zeus

    Hello Sajid
    Hope you having a great day
    I have done as you requested back up then deleted the upfront theme uploaded loaded the latest upfront 1.6 still has same problem of no control panel for up front where in edit mode do you have any helpful suggestion please
    kind regards
    BEAR

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR,
    Hope you are doing good today :slight_smile:

    At this point, I am out of ideas to be honest. Let me escalate the ticket and ping one of our Upfront developer here for his invaluable feedback on this matter.

    He will be in touch as soon as possible. Thanks for your patience on this issue.

    Have a nice day and merry Christmas :slight_smile:

    Best Regards,
    Sajid

  • BEAR
    • Site Builder, Child of Zeus

    Hello Sajid

    Thanks for the quick reply
    I just remembered looking at my ftp setting it looks like you had been using port" 22 "where you need to use port" 21" :slight_smile:can you please re check just to double check

    Have A great christmas:upside_down:

    Regards
    Bear

  • Sajid
    • DEV MAN’s Sidekick

    Hello bear :slight_smile:

    I tried again with port 21 and get following error this time instead:

    Command:	open "F137904@202.59.111.200" 21
    Error:        	Server unexpectedly closed network connection
    Error:        	Could not connect to server

    If you are using FileZilla, can you please send me export/configuration file for this FTP account ?

    If yes, then you would have to upload on your own site or google drive and share the downloadable (make sure this is accessible and downloadable) link with me via email (send in the reply of email you receive from us).

    Best Regards,
    Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR,
    Hope you are having a great day :slight_smile:

    I got the FileZilla configuration file and surprisingly it worked this time yay....

    I can confirm that you have installed the latest version of Upfront parent theme on your website with latest version of Fixer child theme.

    Upon further investigation, I noticed that the Upfront Editor is working fine on a default page. I created a new page called WPMU TEST Page and Upfront editor works fine here.

    It also, works fine using Upfront Builder plugin.

    So, that means, there is something wrong on your home page that is breaking the editor. Do you remember what element you added, after that it stopped working ? Did you added any custom code using embed/code element ?

    Best Regards,
    Sajid

  • BEAR
    • Site Builder, Child of Zeus

    Hello Sajid
    Hope you are having a great day

    Great news to hear you are seeing the same problem:slight_smile:
    I don t recall changing any custom code as code I don't touch,I just can not see the glitch
    Can we investigate this matter further this matter further please!

    Best Regards
    BEAR

  • Sajid
    • DEV MAN’s Sidekick

    Hello BEAR :slight_smile:

    Please accept my sincere apologies for delay on this ticket. It is a weird issue that none of us could replicate on our own test site with Upfront that mad it hard to troubleshoot and fix.

    However, as you know it works on other pages and not just on home page only. So we come up with a work around for you until its been fixed and released. Here are steps.

    1. Visit a blank page, for example WPMU TEST page (I created this blank page for testing).

    2. Launch Upfront editor on this page.

    3. Now click on Upfront logo on top left corner of the upfront panel while Upfront Editor loaded (see screenshot).

    4. This will take you to home page where you can not add/edit the elements.

    Hope that helps! Feel free to post a reply if you need further assistance.

    Take a ver good care of yourself and Happy New Year :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.