Upfront editor not working for several of the themes

The Upfront editor does not work for particular themes such as "Fixer","Gillie Brown","Luke & Sara" and "Issue". The editor stops rendering at 15%.

  • Denitsa
    • WordPress Warrior

    Hello Wray,
    I hope you're having a great day and thank you for your question!

    I am unable to replicate this on my sandbox site here, so I think it's your website specific issue.

    Does this issue occur with other Upfront themes, like Spirit?

    You could also try resetting a theme from Upfront -> General under Debug Options hitting the Reset Theme button. Please make sure to backup before doing this, as it would reset your current active theme to default.

    I can't access your site due to a "Site under construction" message. Could you please disable maintenance mode so I'll be able to take a closer look via the support access you've granted?

    Keep us posted!

    All the best,
    Denitsa

  • Nithin
    • Support Wizard

    Hey Wray,

    Hope you are doing good today. :slight_smile:

    I checked your website, and it seems more like a dependency issue, could you please try adding the following code in your wp-config.php file, which is located in your root directory.
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    Please make sure to place the above code, just before the line /* That's all, stop editing! Happy blogging. */

    You'll have to make use of a FTP application, like for eg FileZilla, to edit the wp-config.php file.

    Please do let us know how that goes, so that we could give a closer look, if needed. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Wray,

    Hope you are doing good today. :slight_smile:

    I checked your website, and I could notice what you have mentioned, I was able to notice 500 internal error in your websites console, so I tried deactivating all the plugins related to BoldGrid, and now Upfront does seem to load, but I could still notice anomalies in your website, when Upfront is loaded.

    Could you please try increasing the memory limit, and then see whether it helps?

    To increase your memory limit, you'll have to create a php.ini file inside your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 256M
    post_max_size = 512M
    memory_limit = 1024M
    file_uploads = On
    max_execution_time = 300

    I'm also able to notice the following errors in the browser console, so I'm pinging the developers for their feedback regarding this issue:

    GET http://YourWebsiteURL.com/upfront-dependencies/scripts/ae956af5fd898697acda7f02c3cf5c35 404 (Not Found)
    
    Uncaught SyntaxError: Unexpected token <

    Will keep you posted, once I get an update from the developer asap. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Wray,

    I just got an update from the developer, could you please send us your FTP credentials so that I could give a closer look. You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Best Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Wray,

    Hope you are doing good today. :slight_smile:

    Thank you for sending in the credentials, but unfortunately when I log in using FTP, it's listing an empty directory, there isn't any way to add check your folders.

    Regarding WordPress credentials, please grant super admin permission to the current login credentials you have passed. Please correct these, and let me know once you have made the changes, or you can re-send the credentials the same way as before, if there is a change your login credentials.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Wray,

    Thank you for correcting the FTP credentials, I was able to notice that you added the code given in my previous reply, after the line /* That's all, stop editing! Happy blogging. */

    The code should be added before, the line /* That's all, stop editing! Happy blogging. */ in your wp-config.php.

    I have made that change, and once I cleared the browser cache, Upfront started to load fine, without any issue. However I'm noticing 500 error in the console, to clear that error out, I would like to check your network admin. The dashboard credentials that you have passed, doesn't have super admin privileges, so I wasn't able to check your network dashboard.

    Could you please enable support access, so that I could give a closer, and get that sorted asap. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that I could get this fixed asap. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Wray
    • Design Lord, Child of Thor

    Nithin,
    I am still having trouble with your upfront editor. After many tries on different themes, Your upfront doesn't want to work or even execute. This is very serious for me since I have committed to your themes and editor.
    I am debating whether or not to commit to another framework and editor.
    I cannot waste any more time on this matter.
    I have not heard from you in several days. Whats going on??

    Wray

  • Nithin
    • Support Wizard

    Hi Wray,

    Terribly sorry for the delay, we do follow a queue when it comes to replying to threads, please do note that sending multiple responses in a thread, will push your thread down the queue, and hence it delays the response time.

    By the way.. Did you put an "Error code: 400" on my Home page.

    No, there hasn't been any such changes made in your system, that would have caused 400 error, the only change done was in the wp-config.php file as mentioned above.

    It seems like your website is in maintenance mode, and the credentials that you had shared isn't working anymore. If you are looking to troubleshoot this further, could you please enable support access, and please do let us know once you have enabled the support access, we won't be able to know if the support access is enabled if you didn't notify us.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Wray,

    Hope you are doing good today. :slight_smile:

    I'm afraid, I'm not able to access your website through support access, I'm getting the following screen:

    You might have to disable the under construction mode, for us to check your website. Please do let us know once you have disabled it, so that we could access your website through support access.

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.