upfront editor shows blank screen

Hello,
I've been using Upfront to customise Spirit for a couple of days on a local development set-up with Vagrant/VVV.

Today, I get a white page next to the Upfront editor sidebar. I tried to restart vagrant and the browsers (Mac Chrome, Firefox). I tried to choose the home page using the page button in the Upfront editing sidebar. Nothing has worked.

The home page (the only page I've worked on so far) looks fine, except a region near the bottom of the page that should have a Google Map is blank.

I believe I'm running the current version, but I don't recall if this started immediately after I updated. I don't think it did.

Any ideas for fixing Upfront?
Thanks,
Morgan

  • Nastia

    Hello @Morgan, I hope you are well!

    Would you please, check for errors in the browser console?

    Run a quick plugin conflict test as illustrated in getting support manual (flowchart). Deactivate all the plugins, and test again. If the issue is gone, activate the plugins one at the time while testing the issue.
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Once we rule out a conflict with a plugin, please configure php.ini file.

    To fix this issue, make sure "max_execution_time" time limit is set to highest possible in php.ini and also "request_terminate_timeout" php-fpm configuration must match. Also try to increase "fastcgi_read_timeout" value nginx configuration. The following answer on stackoverflow will definitely help you fix this issue.
    http://stackoverflow.com/questions/16002268/prevent-nginx-504-gateway-timeout-using-php-set-time-limit/17511476#17511476

    Let us know how it went!

    Kind Regards,
    Nastia

  • Morgan

    Hello,
    Thanks for the quick reply. I forgot to mention in my first message that I turned off all the plugins and the Upfront editor screen is still blank (except for the editing sidebar). Strangely, the public page is fine. It only shows blank when trying to edit.

    I haven't made any changes to my dev environment. It is vagrant using VVV with the site created using vv defaults.
    https://github.com/bradp/vv

    max_execution_time
    is 30, which I think is the PHP default. You suggest 'set to highest possible'. What is that?

    request_terminate_timeout
    I couldn't find this in php-fpm.conf
    In /etc/php5/fpm/pool.d/www.conf, I think it is inactive
    ;request_terminate_timeout = 0

    fastcgi_read_timeout appears to be set very high in VVV (/etc/nginx/nginx-wp-common.conf)
    fastcgi_read_timeout 3600s;

    The editing sidebar and blank page appear pretty quickly, within about 5 seconds, so I don't think timeout settings are the issue.

    The browser console shows one error and one warning. Both appear when the page loads for editing and without the editing sidebar. I'm not sure if they are relevant. The error might be related to the Google map not appearing in a region (but it did work before this started).

    Error 1
    Uncaught SyntaxError: Unexpected token /init_map @ 6332822d62992b965c1beaf8d66a0bc4?ver=0.1.7:1709(anonymous function) @ 6332822d62992b965c1beaf8d66a0bc4?ver=0.1.7:1738m.extend.each @ jquery.js?ver=1.11.3:2m.fn.m.each @ jquery.js?ver=1.11.3:2upfront_bg_map_init @ 6332822d62992b965c1beaf8d66a0bc4?ver=0.1.7:1736m.event.dispatch @ jquery.js?ver=1.11.3:4r.handle @ jquery.js?ver=1.11.3:4m.event.trigger @ jquery.js?ver=1.11.3:4e.event.trigger @ jquery-migrate.min.js?ver=1.2.1:2(anonymous function) @ jquery.js?ver=1.11.3:4m.extend.each @ jquery.js?ver=1.11.3:2m.fn.m.each @ jquery.js?ver=1.11.3:2m.fn.extend.trigger @ jquery.js?ver=1.11.3:4window.upfront_maps_loaded @ 6332822d62992b965c1beaf8d66a0bc4?ver=0.1.7:1753(anonymous function) @ VM267:1(anonymous function) @ main.js:30(anonymous function) @ main.js:29(anonymous function) @ main.js:30mg @ main.js:30(anonymous function) @ VM266:1Qh.main @ main.js:63(anonymous function) @ main.js:41(anonymous function) @ main.js:29(anonymous function) @ main.js:29(anonymous function) @ main.js:29ig @ main.js:30eg.(anonymous function).Qd @ main.js:29(anonymous function) @ places.js:1

    Warning 1 (jquery.js)
    The specified value "!" does not conform to the required format. The format is "#rrggbb" where rr, gg, bb are two-digit hexadecimal numbers.

    Please let me know if you need more info. If no other ideas, I could try shifting it to a web host and see if that makes a difference. It would rule out whether it's something to do with the vagrant settings.

    Morgan

  • Morgan

    Hello,
    I have a few updates. I tried changing from Spirit to another Upfront child theme and back again. No difference. I also found an older version of Upfront (0.4) and uploaded that. The editing got stuck on 'Loading'. I removed it and reinstalled the current version (0.41) and it returned to what it was doing before, which is a blank page.

    Working with Upfront and Spirit, I am effectively 'locked out' of editing my site. The home page looks fine when viewed publicly. It appears as the editing sidebar and a blank space when I try to edit.

    I'm new to Upfront. It would not be a lot of work to start over, but I would like to know how to solve this should it ever happen again. If there is no solution, I probably shouldn't use Upfront. I've lost a couple of days to this.

  • Nastia

    Hello @Morgan, I trust you are well!

    Please try debugging it, by adding this code to your wp-config.php file:

    error_reporting(E_ALL);
    ini_set('display_errors', 1);
    define( 'WP_DEBUG', true);

    Are you using any caching plugins (such as W3 Total Cache)? If so, could you please empty all caches, disable caching at all and see if it helped?

    Is this problem occurring when you trying to edit your home page only? Can you create another page/post via WP Dashboard and after viewing it select "Upfront" button on the top of WP menu, to see if the edit mode will work. See attached screenshot.

    The browser console shows one error and one warning. Both appear when the page loads for editing and without the editing sidebar. I'm not sure if they are relevant. The error might be related to the Google map not appearing in a region

    Please create a new home page, then navigate to WP Settings -> Reading and set the new Home page as a Front page as shown in the attached screenshot 2. If this works, then the issue is releted to Google Maps.

    max_execution_time is 30, which I think is the PHP default. You suggest 'set to highest possible'. What is that?

    You can change max_execution_time to different times, for example 300 ( 5 min.). If a script runs for more than the max_execution_time, PHP will return a timeout error and terminate the script.

    Let us know how it went!

    Kind Regards,
    Nastia

  • Morgan

    Hello Anastasia,
    How are you? Thanks very much for the additional suggestions.

    First, a couple of updates of things I tried before getting your reply:
    1) I managed to migrate the site to test-mrt.dreamhosters.com and turned on support access. Strangely, inability to edit the home page appears to have resolved itself on Dreamhost.
    2) I also created a new site on my laptop in VVV and copied my site to a fresh WP install. (The new migrate feature in Snapshot is really useful for this!) There was no apparent change from the original site in VVV when all this started.

    Does this suggest a possible conflict with the settings in Vagrant/VVV? I'm not sure about this because it worked for a long time before the blank screen started.

    All plugins remain off. This is still in development, so there are no caching plugins in use and no other optimisation plugins.

    I also noticed that the Reading setting has mysteriously changed from a static front page to recent posts since I started working with Spirit. I don't recall making that change and this site had always been set to static before.

    Although I had a static front/home page before starting to use Spirit, the changes I made upon installing Spirit were to the existing home page that appears for that theme when it's installed. When I change to my old home page, it shows the original page. I'm not sure what page Spirit is using for a home page.

    Changes to max_execution_time = 300 don't appear to have any effect.

  • Morgan

    Hello Anastasia,
    How are you today?

    I think I've stumbled upon the source of this problem and fixed it! It might be a repeatable bug to refer to the dev team.

    I think ticking the 'Use Custom Map Code' for the region near the bottom of this page but forgetting to put any code in caused the whole page not to display when trying to edit it.

    1)
    On my laptop, with the site running in Vagrant/VVV, I turned off WiFi. The next time I tried to edit the page, it appeared as normal. I unticked the box in the map region settings, saved the page, left Upfront editing and turned WiFi back on. When I returned to Upfront to edit the page, it displayed!

    I was able to bring back the undesirable behaviour and fix it by ticking the Custom Code box again and repeating the steps above.

    2)
    It's a little more difficult to troubleshoot and fix this problem when the site is on a web host. I opened the Network settings on my laptop and changed the DNS to the web host's DNS. This had the effect of making my laptop only able to access web pages at the web host's servers. Its DNS would not respond to requests for other sites (including the Google map the page was trying to load). I could still access my site on the web host, go to the Upfront edit page, and untick the custom code box. Afterward, I could revert to my usual DNS, access any website and edit the page as before.

    I'm very happy to have editing for my site back again and it's great to know how to fix this if it should ever happen again. However, being new to Upfront, I'm a bit concerned such an apparently inconsequential setting could have a bit impact on Upfront's normal function. It makes me wary of using Upfront. I lost a couple of days trying to get things working again.

    The site is still on a test domain and the support access should be good for a couple of days if you want to look at it. I would recommend against trying to repeat the error on the test server as recovering from it is a bit of a pain compared to fixing it in a dev environment (unless you've got an easier way to fix it -- I'm sure there are other ways to remove that setting without the editing GUI). I've got a Snapshot backup of the non-working site that I may be able to make available. It's around 150mb.

    Best regards,
    Morgan

  • Nastia

    Hello @Morgan, I hope you are well!

    I tried to replicate this issue, following the steps you wrote above. But even after restarting Vagrant the Upfron edit mode is working while having ticked on "Use Custom Map Code" option in Google Map.

    I also noticed that the Reading setting has mysteriously changed from a static front page to recent posts since I started working with Spirit. I don't recall making that change and this site had always been set to static before.

    The reading Settings are changing by default to this state when enabling Upfront.

    Either way, we will troubleshoot again and inform our developers, like @Rupok mentioned, about this issue.

    Let us know if you require other information!

    Kind Regards,
    Nastia

  • Nastia

    Hello Roland , I trust you are doing well!

    Thank you for posting in this thread, however, because this issue is resolved for the original author that has posted it plus the original author here were using Upfront beta version, please create a new thread for your issue. This way, the author will not be getting email notifications each time when there is a new post in the thread.

    You can create a new thread here:
    https://premium.wpmudev.org/forums/#question

    Thank you,

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.