Upfront Editor won't finish loading

Hi,
I am experiencing the following problem, I can not load up the upfront editor, every time I try it gives me this message:

"Loading... the Upfront editor may take a while to load (especially first time), please hang in there :slight_smile:"

It continues like this indefinitely. I have tried clearing caches on server and on the browser/client, but nothing works. It's just stuck in perpetual loading. It had been working previously, in fact I had been using it without problems not 15 minutes prior. There were no changes in plugins, updates, or settings between uses.

  • Isaac

    The Console gives the following log entries during loading:

    Uncaught SyntaxError: Unexpected token /
    jquery.js:4
    The specified value "!" does not conform to the required format. The format is "#rrggbb" where rr, gg, bb are two-digit hexadecimal numbers.
    maps.google.com/maps-api-v3/api/js/23/8/util.js:23
    Google Maps API warning: SensorNotRequired https://developers.google.com/maps/documentation/javascript/error-messages#sensor-not-required
    Uncaught SyntaxError: Unexpected token /

    I've opened support access. I noticed that I can load other pages with upfront. It appears to have mucked up something just on the homepage. I have no custom code, I strictly used stock upfront features.

  • Alex Stine

    Hello,
    I don't know much about Upfront or debugging JavaScript, but have you tried adding this code to your .htaccess file to bypass mod_security rules that could be blocking a required script?

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    This code should go at the top of your .htaccess. You can access this file via FTP or Cpanel File Manager.

    Thanks,
    Alex :smiley:

    • Isaac

      Thanks, but this is on Nginx via easyengine, .htaccess aren't being used and I'm fairly certain the easyengine team doesn't compile with mod_security support as "nginx -V" gives the following:

      configure arguments: --with-cc-opt='-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-Bsymbolic-functions -Wl,-z,relro' --prefix=/usr/share/nginx --conf-path=/etc/nginx/nginx.conf --http-log-path=/var/log/nginx/access.log --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock --pid-path=/run/nginx.pid --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --with-debug --with-pcre-jit --with-ipv6 --with-http_ssl_module --with-http_stub_status_module --with-http_realip_module --with-http_auth_request_module --with-http_addition_module --with-http_geoip_module --with-http_gzip_static_module --with-http_image_filter_module --with-http_spdy_module --with-http_sub_module --with-http_xslt_module --add-module=/usr/src/packages/BUILD/debian/modules/headers-more-nginx-module --add-module=/usr/src/packages/BUILD/debian/modules/nginx-auth-pam --add-module=/usr/src/packages/BUILD/debian/modules/nginx-cache-purge --add-module=/usr/src/packages/BUILD/debian/modules/nginx-echo --add-module=/usr/src/packages/BUILD/debian/modules/ngx-fancyindex --add-module=/usr/src/packages/BUILD/debian/modules/nginx-lua --add-module=/usr/src/packages/BUILD/debian/modules/nginx-upload-progress --add-module=/usr/src/packages/BUILD/debian/modules/nginx-upstream-fair --add-module=/usr/src/packages/BUILD/debian/modules/ngx_http_substitutions_filter_module --add-module=/usr/src/packages/BUILD/debian/modules/memc-nginx-module --add-module=/usr/src/packages/BUILD/debian/modules/srcache-nginx-module --add-module=/usr/src/packages/BUILD/debian/modules/HttpRedisModule --add-module=/usr/src/packages/BUILD/debian/modules/redis2-nginx-module --add-module=/usr/src/packages/BUILD/debian/modules/nginx-development-kit --add-module=/usr/src/packages/BUILD/debian/modules/set-misc-nginx-module --add-module=/usr/src/packages/BUILD/debian/modules/ngx_pagespeed

      I don't see modsecurity in there, so I would suspect it isn't the source of issues.

  • Milan

    Hello @isaacjohnson,

    Hope you are doing well. :slight_smile:

    I can see few javascript error of "Unexpected tocken /" in my browser console. So have you injected some custom code in theme files or some other plugin ?

    Also please do conduct plugin conflict test as described in our support manual here,
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let me know how it goes for you. :slight_smile:

    Cheers,
    Milan

    • Isaac

      As I've mentioned, there is no custom code, I have turned off nearly all plugins, the only ones left are Jetpack, fail2ban, Smush Pro, WPMU Dev Dashboard, Snapshot, Nginx helper, and redis object cache. I've totally cleared the cache and tried to eliminate anything that could possibly conflict. All the errors seem to be centering around a google maps background that I set for one of the sections. Did upfront get hosed when I set the background to a google map? I strictly used the editor, I did not insert code to do it. :expressionless:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.