UpFront error messages and Toolbox icons gone?

Hi,

I am int Academy Course "Intro to UpFront" and have remade my home-page in the process at http://www.excelstories.com. However I get a strange error message from time to time and the Toolbar elements icons are gone, as well as the icons when editing text for example.

Strange thing is that I managed to make and save all the changes by "guessing" the icons and clicking (the funtionality seems to be there after all).

Have tried Safari, reseting the browser cash and so on. Also tried FireFox with the same results.

Please check the enclosed screen image.

Cheers

Acke
http://www.excelstories.com

  • Rupok

    Hi Acke,

    So sorry to hear the inconvenience you are having. This is really weird and should not happen. Let's try to resolve this.

    At first, can you please do a plugin conflict test just to make sure no other plugin is causing this? Sometimes, this may happen for caching or compressing assets etc. To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Besides this, can you please check on your browser console for errors? I mean, is any error is shown in your browser console when Upfront Editor is loaded? If yes, can you please share those errors with us?

    Does it happen always or this icon disappearing issue happens on random? Can you please confirm? You said "I get a strange error message from time to time", what is that error message?

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm when you are done granting Support Access. I'm looking forward to hearing from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Acke | ideSystem.com

    Hi Rupok,

    1. I have not experienced this kind of problem earlier.
    2. The UpFront error message says: "Another tab is already working on this"
    3. It´s popping up every time I am starting UpFront
    3. In the console I get 10 error messages, se below:
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (style.css, line 0)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (wphb.ttf, line 0)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (wphb.woff, line 0)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (wphb.svg, line 0)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (panel-loader-01.svg, line 0)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (uf-ui-sprite.svg, line 0)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (uf-core-el-sprite.svg, line 0)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (uf-ui-sprite.svg, line 0)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (edit_txt.svg, line 0)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (uf-ui-sprite.svg, line 0)

    Finally, remote support is enabled.

    Cheers

    Acke

  • Nithin

    Hi Acke | excelstories.com,

    Hope you are doing good today. :slight_smile:

    I was able to notice that the icons are missing, but was unable to notice the Another tab is already working on this message in Upfront, clearing the cache should help in removing this message.

    Regarding icons not showing up, did it happen from the start ie once you installed Upfront, or you were able to notice this issue recently, ie was it working before?

    Could you please try adding the following rule in your .htaccess file, and check whether it helps:
    AddType image/svg+xml svg

    Please make sure to clear the browser cache, and cookies in order to see the changes made in the .htaccess file.

    I hope this helps. Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Acke | excelstories.com,

    Hope you are doing good today. :slight_smile:

    I have running UpFront for a year with visible icons. They suddenly dissapeared

    Thanks for mentioning this, I gave a closer look, and I was able to notice JS errors. It seems like there is some dependency issues with the scripts, when it's minimized. I have disabled Hummingbird minification at the moment, and have optimized Upfront, under Upfront > Experimental . Now the icons are back in the Upfront editor.

    To correct this, please add the following line in your wp-config.php file, located in your root directory:
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    Please make sure to place the above code, just before the line /* That's all, stop editing! Happy blogging. */

    Once you add the above code, you can enable minification. Please do note, if you are working on your website, would recommend you to disable minification. Minification is meant to be enabled, only when you have finished working on your website, ie when it's live.

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Acke | ideSystem.com

    Hi Nithin,

    thank you so much for nailing down the issue. It´s makes sense, since I started to tweak Hummingbird when you release WP Checkup with the site performance report.

    When clicking remove Minification the icons are back in UpFront :slight_smile:. However my site http://www.excelstories.com started to behave really strange and guess what - the htAccess file was empty. Replaced it with a backup copy and now everything is humming again.

    Will not enable minification, since it is not compatible with the Hummingbird for now.

    Thanks for great support. Issue solved!!

    Cheers

    Acke

  • Nithin

    Hi Acke | excelstories.com,

    Will not enable minification, since it is not compatible with the Hummingbird for now.

    Maybe I'm missing something here. But just to be clear, I had disabled the minification settings, under Hummingbird > Minification temporarily, once you have added the code in your wp-config.php as mentioned above, you can enable Hummingbirds minification without any issues, and it's compatible.

    But would recommend to enable minification only after your website is live, or once you have finished working on Upfront. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.