Upfront fixer theme unable to save anything.

I have tried changing multiple elements, even just adding a simple text box, I click save and I see the saved settings acknowledgment. Then I try to exit, and I get a settings not saved warning. I try to exit and the edits did not save. Tried numerous ways of saving, but nothing sticks.

I have granted access, so hopefully you can replicate and tell me what I am doing wrong.

Thanks,

  • Rupok

    Hi George

    I hope you are having a wonderful day.

    I just logged in your site with Support Access and found the reason why your changes are not being saved. I'm confirming you that it's not a bug of our theme. It's happening because of a configuration at your hosting server.

    I'll suggest you to contact your hosting provider and tell them you have having issues with mod_security. They might have a fix for it.

    First of all, it seems like there is permission issue in your web directory (See attached image for screenshot). All directories should be 755 or 750. All files should be 644 or 640. Exception: wp-config.php should be 600 to prevent other users on the server from reading it. No directories should ever be given 777, even upload directories. You can get more idea here: http://codex.wordpress.org/Changing_File_Permissions

    Secondly, the issue is generated by mod_security. Can you please try putting the following code inside your .htaccess file at the root directory and check if it works?

    <IfModule mod_security.c>
        # Turn off mod_security filtering.  SMF is a big boy, it does not need its hands held.
        SecFilterEngine Off
    
        # The below probably isn't needed, but better safe than sorry.
        SecFilterScanPOST Off
    </IfModule>

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.