Upfront "full post" word limit

To replicate this, add a "Post" element on page, set it to display post list (default settings will work) and then in "Query Settings" set it to show "Full Post" instead of excerpt and in "Post Parts Settings" edit "Content" post part and try to use "Limit words" option. It doesn't work with "Full Post", it only works with "Excerpt".