[Upfront] get "no response data" error

When accessing my site while not logged in, the site does not appear to be loading the css.
From Chrome DevTools, I reload the page, several of the calls are in red, with a message: "Failed to load response data."
I have taken screenshots but cannot attach to this message.
You can probably see the error firsthand if you load https://aventureworks.com.
The errors are referencing an admin page/script that is my visitors would not have access to. I have recreated the problem in FF and Edge.
Can you help me?


John Beacham

  • Nastia
    • Support Rock Star

    Hello Jack Beacham

    Hope you're doing well!

    There are 403 errors showing up in the developer console. 403 is a permission error. Please check your .htaccess file for any rules that might be restricting visitors from viewing your site. Download the .htacess file to your local device and remove it from your site's files. If all is well, go to Settings > Permalinks and resave changes

    If this is not caused by the .htaccess file, check the wp-content file permissions and the folders/files that are located within. All directories should be 755 or 750 and all files should be 644 or 640.

    This also can be caused by a plugin installed on your site. Please deactivate all plugins and see if the issue is resolved. If all is well, activate one plugin at a time, until the issue will be back. This way you will know which plugin is causing it.

    If these will not bring a solution please enable WordPress debug by adding following lines in the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define('SCRIPT_DEBUG', true);

    Please make sure that you insert these lines above /* That's all, stop editing! Happy blogging. */ . Refresh the front end page as a visitor and look for debug.log file in the wp-content folder. Please rename it to debug.txt and attach it in here.

    Let us know how it went!


  • Jack Beacham
    • WPMU DEV Initiate

    Thank you! Still in process. Quick update:
    -disabling .htaccess did not have an effect.
    - disabling all plugins did not have an effect.
    -adding debug code causes a 500 error. :slight_frown:

    Will circle back to my hosting provider and see what they mightbe able to tell me.

    Will update you.

    Thanks again!

  • Nastia
    • Support Rock Star

    Hello Jack Beacham

    Hope you're doing well!

    If your hosting provider will not find a solution, please send to us your FTP credentials so we could have a closer look.

    You can send credentials by using our secure contact form

    Subject: “Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    Looking forward to your email.

    Kind regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.