Upfront Google Map is not working

A background map or an Upfront widget are not working. I already set up my Google map key. The access is already granted. Please, take a look at it for me: http://levarenault4.esites.pro/

Thank you!

  • Sajid
    • DEV MAN’s Sidekick

    Hello diegpl :slight_smile:

    I tested google maps with Upfront Builder on my own test site but could not replicate this issue. Its working just fine for me.

    Thanks for granting support staff access. I could replicate this issue on your site and found the culprit. Its your API project that is not valid or not allowed to use on this site. I see following error in JS console of chrome browser.

    This API project is not authorized to use this API. Please ensure this API is activated in the Google Developers Console: https://console.developers.google.com/apis/api/geocoding_backend?project=_ For more information on authentication and Google Maps Javascript API services please see: https://developers.google.com/maps/documentation/javascript/get-api-key

    Also see screenshot taken from your site:

    Please see this official Google documentation to get the API key and used that one on this site.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,

    Sajid

  • Nastia
    • Support Rock Star

    Hello diegpl , I hope you are doing well!

    Please go to this link here.

    Select a project that you already have or create a new one if you don't have.

    Click on Continue button.

    On the next step, do not change anything, click on Create Credentials.

    Copy the API key and place it in Upfront > General > Api Keys

    Let me know if you have any further questions!

    Cheers,

    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.