Upfront interface not working

I am no longer able to edit my Upfront theme. When I go into the Upfront editor from wp-admin I just get the website itself. This goes for editing the current theme as well as using Builder or changing to another theme.

I have tried disabling all plugins, clearing the upfront cache and switching themes.

I have also followed the discussion here, and was advised to create a new ticket after posting a comment: https://premium.wpmudev.org/forums/topic/upfront-interface-breaks-after-adding-second-image#post-1178258

Support access has been granted.

  • Nastia
    • Support Rock Star

    Hello Madsi Nordbustad , I trust you are doing well today!

    Please let us know what are the changes you made on your site before the Upfront broke? I am not getting any errors in the developer console. Have yu tried adding the following code to your wp-config.php file?
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    As it looks Upfront is not loading with any of the child theme and on none of the pages. If the above solution will not work, please add the following code to your .htaccess file:

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    If mod_security is enabled on your site, the above code will unblock access to Upfront js files, and the Upfront should load again.

    Let me know how it went!

    Cheers,
    Nastia

  • Madsi Nordbustad
    • Flash Drive

    I haven't done a lot on the site that didn't involve plugins and those are all deactivated now. I recently set up a redirect from www to non-www in redirect and I have done a few changes in wp-config. I also haven't had time to much except remove some stuff from the Upfront child theme and change the header.

    Most recent thing I did was install Builder today, and update the upfront theme. However I haven't been in the editor for a while so I can't say that that is necessarily related.

    I have set wp-debug to true in wp-config, including the line you mention, but I don't get any error messages.

  • Nastia
    • Support Rock Star

    Hello Madsi Nordbustad , I hope all is well!

    Would you please send to us your credentials so we could have a closer look?

    You can send credentials by using our secure contact form http://premium.wpmudev.org/contact/

    Subject: “Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    Select “I have a different question” for your topic - this and the subject line to ensure that it gets assigned to me.

    We are waiting for your email!

    Kind regards,
    Nastia

  • Predrag Dubajic
    • Support

    Hi Madsi,

    Issue with Upfront loading seems to be related to your caching plugin, when I checked your wp-config.php file and commented out lines 3 and 4 which are created by your caching plugin the Upfront started working again.

    These are the lines I'm referring to:

    define('WP_CACHE', true); //Added by WP-Cache Manager
    define( 'WPCACHEHOME', '/srv/users/serverpilot/apps/madsico/public/wp-content/plugins/wp-super-cache/' ); //Added by WP-Cache Manager

    I would suggest leaving your caching plugin off while making changes on your site and then enable it back one once done.

    When you're about to make changes with Upfront editor you can go to your caching plugin settings, clear up the cache and after that disable the plugin.
    This should work without making changes to your wp-config.php

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.