Upfront Kind of Buggy

I am finding Upfront to be kind of buggy these days. First of all, I was getting a blurry "oops something went wrong" and somehow I fixed that. Then I was having great difficulty editing pages, specifically adding content. Formatting problems. I cannot see the "padding" and "settings" tabs on top of the section I am trying to edit. Then, on top of it all, now I have the blurry, "oops, something went wrong" again. Is there a way I can re-install Upfront? Or how else can I fix these problems?

I've granted permission.

  • Milan

    Hello John ,

    Hope you are well today and thanks for asking us. :slight_smile:

    Have you conducted plugin conflict test as described in our this support manual ?
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If not, please do it now and let me know how it goes.

    Furthermore, after taking look at your site, I can't find any such problem. Upfront editor loads without issue for me, I was able to tweak element's padding and margin. Can u tell me how can i replicate issues on your site ? Something like step by step guide ?

    Best Regards,
    Milan

  • John

    Hi Milan

    Thanks for your quick response.

    First of all, here's how to replicate the issue: from the dashboard, click Upfront from the top admin. Once Upfront has loaded (it does indeed load), select Posts/Pages (to edit a page), example About Us, on loading, I get this:

    Here's what I have done: I have disabled all plugins, including WPMU Dashboard. I have replicated this on both Chrome and Firefox. I have also flushed the browser cache and the GoDaddy Cache.

    Thanks!

  • Milan

    Hello John ,

    Hope you are doing well today. :slight_smile:

    Thanks for providing me staff access to your site and describing steps to replicate the issue. :slight_smile: But issue here is that I am not able to access your site.

    When I try to access your site, I am getting this error, :slight_frown:

    To resolve this, please revoke granted staff access and then regrant me again. It will help us to eliminate this not letting me access your site.

    Once you revoke and regrant me staff access, please do let me know. :slight_smile:

    Best Regards,
    Milan

  • Adam Czajczyk

    Hello John,

    Thanks for granting an access!

    I checked the site and I can confirm the issue. I did however noticed two issues that seem to be related:

    1. After several attempts to switch between the pages (in Upfront editor -> "Posts/Pages - Edit") they started to load fine; then after leaving editor and entering it again the same happened.

    2. I'm also not able to access any part of "Upfront" menu in site's dashboard

    I think these may be related. At first I suspected cache but flushing it doesn't help and also I've seen Upfront working fine on GoDaddy's hosting many times so I think this is something different.

    This leads me to the question: have you tried to adjust Upfront's "User Restrictions" settings ("Dashboard -> Upfront -> User Restrictions") or Upfront's "Experimental features" ("Dashboard -> Upfront -> Experimental") before that started to happen?

    Also, I can't see any user-role management plugins there so just to make sure: you didn't alter any default user-role setttings/capabilities in any way, is that right?

    Please advise!

    Best regards,
    Adam

  • Adam Czajczyk

    Hello John!

    Thank you for your replay.

    That's it. I am also not able to access the Upfront menu, but was going to deal with that in another post. (There's something about not putting too many things in one post)

    It's a good practice to keep tickets as "specific" as possible but in this case I got a feeling that these issues may be related so let's for now keep them both together here.

    Also, there are no user management plugins, and no, I have not altered the default user settings. I did put something in the wp-configure file, which was about debugging. I'll check that, or you can, if you can.

    I definitely could if I could but I can't so I couldn't do this :slight_smile: That's because the support access tool doesn't give as any access on the "WP install/files" level. Having said that, I think it's time to get more direct approach so I'd like to access both your site and server directly.

    Please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) ; cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here http://premium.wpmudev.org/contact/

    Select "I have a different question" from the drop-down list. 

    Please be sure to make a full backup of your entire site first!

    Best regards,
    Adam

  • Adam Czajczyk

    Hello John!

    Thank you for providing me with all access credentials.

    I reviewed the site and the setup again and I made following changes:

    - in /wp-content/ folder of your site install I removed the "object-cache.php" file which is a "leftover" from W3 Total Cache and since the plugin is not install it shouldn't be no longer there;

    - in ".htaccess" file I found out that some rules are doubled so I commented them out

    - I re-uploaded fresh copies of both Upfront and Spirit to the site

    - I raised WP memory limit in "wp-config.php" file

    Currently, Upfront editor seems to be working for me each time I try it regardless whether I'm accessing it via "Upfront" link from the dashboard or directly; I cannot replicate the issue anymore on your site.

    However:

    1. The "Upfront" menu in dashboard doesn't work as expected still
    2. I'm still not 100% sure whether Upfront works "just for me" or if this fixed the issue "for good".

    That being said, please clear your browser's cache and give it some tries again. Let me know if Upfront is now working for you or not.

    If it's not, please don't remove any access that you already provided me with (including temporary admin account on the site) and I'll keep investigating it.

    Best regards,
    Adam

  • John

    Hey Adam. I've had a look with Chrome and Firefox, did a couple of tests, and it all seems to be working quite well.

    But yes, the Upfront Menu still says I don't have sufficient privileges to access it. I hadn't really used that menu, so no big deal, but if you're like me, it kind of gets to you if it doesn't work. So I guess I am not sure that we are done here.

    Thanks again for the great help this far. Very happy with your amazing help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.