Upfront no loading

Hi,
I see different topics about the same issue, upfront is not loading correctly, no popup, or not loading at all.
It's a multisite network with domain mapping, exemple on this mapped site : http://chickenyls.com
The background images appears blank and it's not possible to edit any images, it was working earlier when the site was getting built.
I believe it is a host issue at page.ly, if you could point me it the right direction ?
Access is granted if you need.
Thanks a lot,
Thibaud

  • Rupok

    Hi Thibaud, hope you had a wonderful day.

    Thanks for granting Support Access to "clic.space" but there I could not find any subsite mapped to http://chickenyls.com . Can you please provide on which site or subsite, I can see your issues live? In my test site, all functions are working perfectly, so I suspect this is your site/hosting specific issue.

    I'll jump in and test as soon as you confirm which site to check. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi Thibaud, hope you had a wonderful day.

    I just checked your site and it seems like two stylesheets are getting 500 error from your server. Please check the attached screenshot for reference.

    Most probably that's the reason. Moreover, I can't access dashboard of that specific subsite, it's asking me to login though I'm logged in Network Dashboard.

    So can you please talk to your host regarding those 500 errors, and allow us to change Domain Mapping Settings so we can access that subsite too for investigating further?

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi Thibaud,

    Hope you are doing good today. :slight_smile:

    I was having issue with your mapped domain, so I created a new subsite uptest, and I'm able to confirm the issue in your new subsite too. Could you please try increasing your memory limit, and check whether it makes a difference.
    For Eg:

    upload_max_filesize = 200M
    post_max_size = 500M
    memory_limit = 1024M
    file_uploads = On
    max_execution_time = 180

    Please create a file php.ini, and place it in your root folder, and add the following rules, or increase/decrease it according to your server limit. Please check this link for more information: https://premium.wpmudev.org/blog/increase-memory-limit/

    I hope this helps. Please let us know what your host has to say about 500 issue, so that we could give a closer look. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Thibaud

    Hello,
    this is the response from my host.
    However I double checked and uploaded a fresh version of upfront and no file is missing...
    Let me know,
    Thanks,
    Thibaud

    Hi,

    I think the error might be caused because the either the filename "70f434ce31ea59553b069b4d6ab013ab" isn't actually present in the project's wp-content directory:

    ###

    s14666.sites.p20.sites.pressdns.com:80 80.215.3.107 - - [13/Jul/2016:17:57:49 +0000] "GET /upfront-dependencies/styles/70f434ce31ea59553b069b4d6ab013ab?ver=1.1.2 HTTP/1.0" 500 279 "http://chickenyls.com/le-menu/" "Mozilla/5.0 (Linux; Android 6.0.1; D6503 Build/23.5.A.0.575) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.81 Mobile Safari/537.36" 607925

    rskeensTim:disappointed:data/s2800/dom14666/httpdocs$ find wp-content -name "70f434ce31ea59553b069b4d6ab013ab"
    rskeensTim:disappointed:data/s2800/dom14666/httpdocs$

    ###

    For some reason it then generates an internal server error rather than a 404 response. Would it be possible for the asset to be saved in the project's workspace and also if possible that it contain the ".css" file extension?"

    Regards,
    Roscoe

  • Nithin

    Hi Thibaud,

    Hope you are doing good today. :slight_smile:

    Upfront doesn't behave like a basic WordPress theme as it has it's unique Framework, and Drag & Drop API's, when it comes in rendering CSS what you have pointed out are dependency scripts, and that's how the theme behaves.

    Did you try increasing your memory limit as mentioned in the previous reply?. It looks like the support access is not enabled anymore, could you please grant support access, so that we could troubleshoot it further. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual.

    Please let us know once you enable access, so that we could give a closer look. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Thibaud,

    Hope you are doing good today. :slight_smile:

    Your subsite is redirecting to a login page, is it okay to switch your Domain Mapping settings off?, so that we could check it. It seems like the PHP settings are still the same regarding memory limit, and other values. Please let us know once you make those changes, so that we could give a closer look. Increasing these values does make a difference, we would like to check your website once you make these changes.

    Please let us know how that goes, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Thibaud

    Hi,
    lassât response from page.ly:
    "Hi,

    I can certainly understand the frustration but our Neutrino service tier utilises a singular PHP configuration which means that adjustments for an individual application would likely cause unintended consequences for other customers which share the same platform. Our VPS service tier on the other hand use isolated instances of PHP which can then be customised.

    We can help wherever possible and I have gone ahead and defined the "UPFRONT_DEBUG_LEVELS" constant definition. At the present moment the website doesn't appear to load the randomised asset filenames such as "70f434ce31ea59553b069b4d6ab013ab" but I do believe that if they were stored locally and named as CSS file extensions, then that should present a workaround.

    The functionality of your website is very important to us but in some instances either the theme or plugin is not suitable for the service tier or it should be adjusted as a compromise others many other customers can be adversely affected.

    Regards,
    Roscoe"

  • Nithin

    Hi Thibaud,

    Hope you are doing good today. :slight_smile:

    I did ping the developer regarding this, but I'm afraid, one of the key things for Upfront to not load is, your server not having enough memory resource. Could you please share your PHP server logs, please make sure to load Upfront before sharing the log files, so that we could pick any errors related to this issue. Make sure you attach the file in txt format in your next reply, or use a cloud service like Dropbox to share the log files.

    At the present moment the website doesn't appear to load the randomised asset filenames such as "70f434ce31ea59553b069b4d6ab013ab" but I do believe that if they were stored locally and named as CSS file extensions, then that should present a workaround.

    These are dependencies files, that are needed in order for the theme to function properly. Upfront doesn't work like a standard WordPress theme, it has it's own framework, and an unique Drag & APIs. I'm afraid storing the file locally, with a CSS extension wont work in this case.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Thibaud

    Hi,
    thank you for your help.
    Maybe it has to do with domain mapping? Main site and multisite subdomains are wildcard SSL, this mapped domain http://chickenyls.com doesn't.
    This is the last response from page.ly:
    Hi,

    We unfortunately can't increase PHP limitations for a single application since it is a commonly shared configuration amongst different customers. Have the dependency assets since been disabled? The prior files don't appear to be referenced during a pageload test:

    https://tools.pingdom.com/#!/cjmJ0F/http://chickenyls.com/

    ###

    $ lynx --source chickenyls.com | grep "upfront-dependencies"
    $

    ###

    Checking further I did notice the following request as part of the pageload:

    https://chickenyls.com/wp-admin/admin-ajax.php?action=upfront-element-styles&key=70f434ce31ea59553b069b4d6ab013ab&ver=1.1.2

    Your website doesn't utilise an SSL Certificate and could potentially be influential regarding the reported error. It would be recommended that it please be adjusted to http:// instead of https://

    Regards,
    Roscoe

  • Nithin

    Hi Thibaud,

    Hope you are doing good today. :slight_smile:

    Maybe it has to do with domain mapping? Main site and multisite subdomains are wildcard SSL, this mapped domain http://chickenyls.com doesn't.

    Thanks for pointing that out, I'm not sure about it. While checking your browser console, I'm getting a http link, and not https. Didn't your theme used to work before? If you still think, it's related to SSL issue, if possible, please try the suggestion made by your host.

    Could you please check your server logs, and see whether you are getting any errors like:
    tried to allocate X bytes

    If yes, these errors relate to having a low system resource.

    Sorry to keep this thread long, please do let us know how that goes. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Thibaud

    Hi,
    I'll check for error "tried to allocate X bytes"
    and just sharing another response from page.ly:
    Hi,

    Thank you for the update. It would seem that the "upfront-dependencies" assets still don't seem to be associated with the pageload in order to confirm:

    https://tools.pingdom.com/#!/d15Y8S/chickenyls.com

    I also encounter a 404 error on my end regardless if HTTP or HTTPS is specified:

    https://chickenyls.com/upfront-dependencies/styles/70f434ce31ea59553b069b4d6ab013ab?ver=1.1.2%20HTTP/1.0
    http://chickenyls.com/upfront-dependencies/styles/70f434ce31ea59553b069b4d6ab013ab?ver=1.1.2%20HTTP/1.0

    It is possible that the developers are perhaps engaged with work concerning the issue but at this stage the website's pageloads are vacant of the problematic files.

    Regards,
    Roscoe

  • Ash

    Hello Thibaud

    At the present moment the website doesn't appear to load the randomised asset filenames such as "70f434ce31ea59553b069b4d6ab013ab" but I do believe that if they were stored locally and named as CSS file extensions, then that should present a workaround.

    It won't work like that, this dependency files are not real files, this is on-the-fly generated one. The upfront code should generate the file when the url is requested.

    Would you please post the following in your htaccess?

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • Thibaud

    Hi,
    my host is now adding the line to htaccess. And here its last response along with the logs:
    "Hi,

    You are most welcome. The application's error log doesn't seem to reference memory exhaustion and almost entirely contains entries related to SQL syntax. I do not believe it is related but I have included an example below:

    ###

    [01-Aug-2016 08:51:11 UTC] Erreur de la base de données WordPress Unknown column 'p.post_published_stamp' in 'where clause' pour la requête SELECT
    c.blog_id as blog_id,
    c.comment_post_id as post_id,
    c.comment_author_user_id as post_author_id,
    c.comment_author as post_author_name,
    c.comment_author_email as post_author_email,
    p.post_title as post_title,
    c.comment_content as comment_content,
    c.comment_post_permalink as post_permalink,
    c.comment_date_stamp as post_published_stamp,
    c.comment_id as comment_id
    FROM wp_site_comments c INNER JOIN wp_network_posts p ON c.comment_post_id=p.ID AND c.blog_id=p.BLOG_ID WHERE 1 AND c.comment_approved = 1 AND p.post_published_stamp > 1469836540 ORDER BY c.comment_date_stamp DESC LIMIT 10 faite par do_action('wp_ajax_nopriv_live_stream_update_ajax'), call_user_func_array, live_stream_update_ajax_proc, live_stream_get_post_items

    ###

    If memory relates error were present then we still wouldn't be able to make any adjustments because your service plan is our Neutrino offering whereas only our VPS service tiers and above permit such adjustments.

    At this moment the problematic "upfront-dependencies" files which were referenced don't seem to be involved with the website's page loads any longer which makes it difficult to ascertain the status of the originally reported issue.

    Regards,
    Roscoe"

  • Thibaud

    Well they are not adding the line finally. I still have problem with upfront page builder, you can check also, access is granted.

    Hi,

    We unfortunately can't disable mod_sec rules without operations approval but what I am trying to say is there currently aren't any 500 errors generated concerning CSS files, which means the original problem is no currently manifesting itself.

    Can we please first confirm that? My browser console doesn't show the problem which was initially shown by the opening screenshot any longer.

    Regards,
    Roscoe

  • Rupok

    Hi Roscoe, hope you had a wonderful day.

    I've informed our Upfront developers regarding your issue and they are currently having a look on it. I believe, they will come up with their valuable feedback soon regarding this.

    Please keep in mind, our developers work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide a feedback.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi Roscoe, hope you had a wonderful day.

    Can you please do a plugin conflict test just to make sure no plugin is causing this? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Moreover, can you please share your PHP error log so we can try to get some idea why this 500 error is happening.

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska

    Hello Thibaud,

    Those are errors from debug.log from WordPress https://premium.wpmudev.org/forums/topic/upfront-no-loading#post-1121702 if I'm correct.
    Our developers asked for server error log to see what is causing error 500. Your hosting provider should be able to check those and provide them.

    We unfortunately can't disable mod_sec rules without operations approval but what I am

    Could they at least for testing purposes add mod_sec filter to htaccess to exclude that this is problem. Add, test if works - if not, we will investigate more. But at least we should be able to exclude possibility that mod_security is culprit here.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.