Upfront not letting me edit network site

Hello. For some reason the Upfront editor is not letting work on one of my network sites. See attached screenshot. The link is grayed out and inactive. I'm logged in as the network admin and permissions look good on Upfront settings.

  • Adam Czajczyk

    Hello Randy,

    Thank you for granting an access!

    I reviewed the site and checked Upfront. I can confirm that I was able to replicate it on your site, however I was also able to get to "loading Upfront" stage - though it didn't load finally.

    I'd suggest starting with basics (please check for an issue after each step):

    1. Your WordPress is set to use only 64M of available PHP memory. That's not much and is often causing issues so please add following line to your site's "wp-config.php" file:

    define('WP_MEMORY_LIMIT','256M');

    The line should be placed above the "/* That's all, stop editing... " line.

    2. Upfront and its themes may require a bit more resources at load time so it's good to raise values for "max_execution_time" (currently set to 30 seconds) and "post_max_size" (currently set to 8M) PHP options.

    This can be achieved in a few different ways. I'd try adding these lines to the ".htaccess" file of your site first:

    <IfModule mod_php5.c>
    php_value post_max_size 64M
    php_value max_execution_time 300
    php_value max_input_time 300
    php_value session.gc_maxlifetime 1200
    </IfModule>

    If this doesn't work or breaks your site, please remove the code and try another way: create an empty "php.ini" file, then put following lines inside and upload the file to the root folder of your site's main domain:

    post_max_size = 64M
    max_execution_time = 300
    max_input_time = 300
    session.gc_maxlifetime = 1200

    Again, if this doesn't work or breaks a site please remove the file and get in touch with your host asking them if they could set these values for you.

    Let me know please if this helped!

    Best regards,
    Adam

  • Milan

    Hello Randy San Nicolas

    Hope you are well today ?

    I just tried to open Upfront editor for your /invictusfitness subsite and it opened up without any issue, Please take a look at this screenshot.

    Can you confirm that your issue is resolved now ? if not then is there something specific you want me to check ?

    Also I've noticed that there is Upfront update available for your site. Please do update it. It is also good idea that you take backup of your whole site before you update your theme. :slight_smile:

    Looking forward to hearing back!
    Cheers,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.