Upfront not saving changes in Fixer theme

Upfront is not saving changes in Fixer theme. Can you help me. Thanks

  • Adam Czajczyk
    • Support Gorilla

    Hello JP,

    I hope you're well today and thank you for your question!

    This is often the case of too low WP memory limit as Fixer is that "heavier" Upfront theme and needs a solid amount of memory at its disposal. That said, please start with following step:

    add this line to your site's "wp-config.php" file

    define('WP_MEMORY_LIMIT','256M');

    It should be located above the "/*That's all, stop editing... " line

    Give it a try please and let me know if it helped. In case it didn't please grant me a support access to your site using our WPMU DEV Dashboard plugin. Here's a guide on how to do this:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello JP!

    Thanks for granting access. I visited your site and tried to edit the home page. I was able to save changes there with no errors now. Could you please clear your browser's cache and give it another try?

    In case it still didn't work, let me know please try other browsers and also let me know which ones have you tried (and on what Operating Systems). Let me also know if this is not about the home page but other page of the site.

    Best regards,
    Adam

  • Milan
    • WordPress Wizard

    Hello JP

    Hope you are well today and thanks for asking us. :slight_smile:

    Seems like my colleague Adam, tested another theme in place of Fixer. It happens as in thread it is set to fixer so he might have assumed that theme which is currently active on your site is also fixer. So when you share your issue with us, please keep environment as is till we say you to do something with it. :slight_smile:

    Now I just tested Fixer theme and I am able to replicate your issue. So could you please add this line in your wp-config.php file to test if this works or not ?

    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    If this does not work, remove line from config file and add these lines of code in your htaccess file. You will find it in your root directory of your site

    <IfModule mod_security.c>
    SecRuleEngine Off
    SecFilterInheritance Off
    SecFilterEngine Off
    SecFilterScanPOST Off
    SecRuleRemoveById 300015 3000016 3000017
    </IfModule>

    Let me know what these changes gives you as result.
    Cheers,
    Milan

  • Predrag Dubajic
    • Support

    Hi JP,

    Strange, the admin-ajax.php file is still showing 404 error on your site when I activated UF editor, this is what Milan's code should have solved.

    Can you get in touch with your server provider and ask them to check server logs to see if there's anything else blocking AJAX requests and admin-ajax.php file?

    Let us know of their response.

    Best regards,
    Predrag

  • JP
    • Design Lord, Child of Thor

    Hi Predrag,

    I see what you mean. Well, I need to get this site development started now, I'm going to use Spirit theme which is working fine.

    I'll contact again if I can get this bug solved. Thanks!

  • Adam Czajczyk
    • Support Gorilla

    Hello JP,

    I visited your new site and performed some more tests. The strange thing is that although indeed it's an "admin-ajax.php" call that's returning 404 error and breaking "save" feature, this doesn't happen when "admin-ajax.php" calls are made during Upfront editor loading.

    I think it'd be essential now to perform a full plugin conflict test in order to either identify or eliminate potential interference from other plugins. I haven't done this however because the new site is actually just a part of your Multisite and it would affect your main site as well. The "staging" site my colleague Predrag asked you about would ideally be a separate WP install that would be a full copy of the current one. Would it be possible that you set it up (on the same server, e.g. in sub-folder)?

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello JP,

    Thanks for letting me access this site. I was able to rule out plugin conflict and after some more tests I feel like we should get back to Predrag's diagnose again. It seems that there's indeed "mod_security" issue and those rules that my colleague suggested didn't disable it.

    I noticed however that you're hosing your site on InMotion Hosting servers. Is this a cPanel hosting? If so, you should be able to disable mod_security for the entire domain via cPanel as described here:

    http://www.inmotionhosting.com/support/website/modsecurity/disable-mod-security-via-modsec-manager

    Could you please give it a try and let me know if this helped?

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello JP!

    I think I'll need to take much closer look then as I'm getting out of ideas. Would you mind letting me access your test site (the quotes.topdev.agency) directly? Please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password)
    -- cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here http://premium.wpmudev.org/contact/.
    Select "I have a different question" from the drop-down list.

    Please be sure to make a full backup of your entire site first!

    Best regards,
    Adam

  • Big Van
    • Design Lord, Child of Thor

    Adam, can you please update here what the fix was? I am having the same problem and it doesn't do me any good to read all the way to the bottom of the thread only to find out the answer isn't posted here. Thanks!

  • Adam Czajczyk
    • Support Gorilla

    Hello Big Van!

    Unfortunately I'm not able to do this because I don't know what happened next. I found out that the site was running on an older version of PHP so I suggested upgrading PHP to at least 5.6.19 and also getting in touch with host and asking them to investigate server logs. I never got any response.

    As we already spoke about this during the live chat, please:

    - search for "mod_security" settings in your cPanel and disable it
    - if there's no such setting ask your host to disable it for you or to white-list your domain

    If this doesn't help, please start your own separate thread :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.