Upfront not using 'Full' sized images

I'm trying to use 'Full' sized featured images in my posts, but Upfront doesn't seem to like it. By checking the source, I can see that it is putting down a resized version of the image (image-name-660x1150-8552.jpg). I have even tried enforcing 'Natural Size' from the image settings, but that doesn't make a difference.

I have stopped WordPress from creating extra versions of my uploaded images from Settings->Media but it seems like Upfront is generating some of them as well which are being used. Is there any way to enforce Upfront to use the 'Full' size of the image? Please advice.

  • Adam Czajczyk

    Hello Enduring Epilepsy (Katrina),

    I hope you're well today and thank you for your question!

    What "Natural Size" option does is actually that when you're adding an image - when you can "move the element area over image" to select part of the image - it uses the image in the original size that you selected while adding an image. However, it still crops an image to the size of the container.

    I see cases when you would want to use an original size though and just let it be dynamically resized by browser. I've asked one of the Upfront developers about it directly to see if we can find some work around for this.

    Please keep an eye on this thread and I'll update it as soon as I get a response from him.

    Kind regards,
    Adam