Upfront & Spirit text editing problem and other improvements

Hi,

First I have to say that Upfront is amazing. So intuitive when building the whole site ground up! Although some things that needs immediate improving:

Text editing is in my site just a pain in the ass. Adding a new line doesn't get done, colors, links, bolds and italics doesn't get applied or get applied the whole paragraph, lines are sometimes impossible to get to work, removing one character or one word removes entire paragraphs, text gets added to the top of the whole text box etc. Don't know why it is so in my site, as long as I can see it works just fine in spirit and scribe demo themes in your site.

I have tried this in localhost and also in my servers and the same happens. Need to get this fixed ASAP

Other things

1) You should be able to "group" two rows for example in the header so you can make them both global. Reason for this: I have one row with white background and it contains the site logo and some other information. Then I have my navigation which should have full width green background and I can only achieve this by editing the background (region) and make the whole region 100% wide. I can't think of any way to do this both in the same region (ie navigation is contained but it's background is full width and on top of that is other blocks and the region background is white.

2) Ordering the blocks is sometimes very hard. They keep jumping everywhere, dragging other things down, the whole editor freezes etc. Normally I can achieve the desired layout but only after many tries, when one time it goes as wanted and I need to do a quick (panic) save so nothing else breaks :slight_smile:

3) Responsive mode with 3 columns: for some reason the spirit/upfront css tries to give column a 22% or 26% (can't remember) width even though it is mobile, tablet or big tablet responsive mode in 1 column. When this happens the entire column is squeezed. I think the desktop responsive is the culprit here somehow. I had to override those in responsive mode css styles, a bit hacky fix but seems to work.

Just my two cents, hopefully you can help me as quickly as possible with the text editing.

  • Tyler Postle

    Hey Jari,

    Hope you're having a great weekend and welcome to the WPMU DEV Community!

    First off, very nice design on your site :slight_smile:

    As for the text issue you're facing, is that only with the text elements? I never experienced the whole paragraph being removed when trying to remove a character or word; however, I did see some spacing issues when deleting characters - could be related, I'll report that to the developers.

    1) You should be able to "group" two rows for example in the header so you can make them both global. Reason for this: I have one row with white background and it contains the site logo and some other information. Then I have my navigation which should have full width green background and I can only achieve this by editing the background (region) and make the whole region 100% wide. I can't think of any way to do this both in the same region (ie navigation is contained but it's background is full width and on top of that is other blocks and the region background is white.

    I can see how this would be helpful. We are looking into the possibility of making other regions global, which would address the issue you're having here :slight_smile: it would take a little while to develop that in, but sounds like many members want the option.

    2) Ordering the blocks is sometimes very hard. They keep jumping everywhere, dragging other things down, the whole editor freezes etc. Normally I can achieve the desired layout but only after many tries, when one time it goes as wanted and I need to do a quick (panic) save so nothing else breaks :slight_smile:

    Using the "grid" option will often make this easier. I've attached a screenshot to illustrate. Some elements can take up a few more blocks than you would expect.

    3) Responsive mode with 3 columns: for some reason the spirit/upfront css tries to give column a 22% or 26% (can't remember) width even though it is mobile, tablet or big tablet responsive mode in 1 column. When this happens the entire column is squeezed. I think the desktop responsive is the culprit here somehow. I had to override those in responsive mode css styles, a bit hacky fix but seems to work.

    This has already been reported and is being worked on :slight_smile:

    Thanks again for bringing this up.

    In the meantime, let us know if you have any further questions!

    All the best,
    Tyler

  • Jari

    First off, very nice design on your site :slight_smile:

    Thanks, we are trying to do our best :slight_smile:

    As for the text issue you're facing, is that only with the text elements? I never experienced the whole paragraph being removed when trying to remove a character or word; however, I did see some spacing issues when deleting characters - could be related, I'll report that to the developers.

    As far as I can see it only happens with text elements. For example I just tried to add a new line (it ends to a <p>/<p> when in frontend I think) and after that tried to just type normally. The word appears but after one space it just disappears. Second thing is that when I try to make a new line in so that the paragraph wont be n+1 lines long, it makes a new line but on TOP of the current one and the words which should have dropped to a new line keep still. You can demonstrate that for example in the home page Lorem ipsum text block. Also I'm not able to drop the list (with green arrows) to a line down. You can demonstrate that by pressing Enter after word interdum. (just before the listing.

    Using the "grid" option will often make this easier. I've attached a screenshot to illustrate. Some elements can take up a few more blocks than you would expect.

    I always use the grid but this happens even if the blocks does have enough space to move and should fit nicely.

    Help & bug fixes with text editing would be greatly appreciated, it keeps me finishing the site..

    Keep up the awesome work and thanks for swift response!

  • Tyler Postle

    Hey Jari,

    Hope you're doing well today and thanks for the updates.

    One other thing: link in a element (image, text link or navigation block links) don't work when elements are grouped. I think this has been reported also but just to make sure it's on the list :slight_smile:

    Yes, this is known and being worked on :slight_smile:

    Updated the Upfront and Spirit but still experiencing similar issues on text editing. Added paragraphs that can't be deleted and skipping lines etc. Would it be good if the text block code could been edited so we could tidy up the code in cases like this? Now it's not so convenient to edit database options to achieve this.

    After updating my issues are fixed now, I'm not getting the weird spacing I was before.

    I tried to replicate what you explained but I'm still not able too. Would you be able to create a screencast of it? Hope that's not too much trouble - Then even if I can't replicate it myself I can still show the video to the developers :slight_smile:

    If you could grant support access then I'll try replicating it on your text boxes too if that's okay.

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Talk to you soon Jari!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.