Upfront stalled at 23% when loading from Chrome and Firefox...

Hello!

I am trying to edit my web site @ h3america.com without success. I have tried using both Firefox and Chrome to launch Upfront to edit the site.

Regardless of the browser, Upfront gets stalled @ 23% rendering the site. I see it load in the background, but I am unable to interact with the Upfront interface.

I have search thru other discussions. I have upped the memory via define('WP_MEMORY_LIMIT', '512M');

I have freed up the cache on both.

There wasn't much else I saw in the first 50 posts regarding Upfront stalling at load or Upfront not loading.

Any of your assistance is greatly appreciated.

Thanks!

Frank...

  • Sajid

    Hello Ibnewbie,
    Hope you are doing good today :slight_smile:

    First of all please make a plugin conflict test as described in our getting support manual to make sure its not a conflict. While troubleshooting, you may need to disable plugin temporarily and try to load the Upfront. If it works, then enable each plugin one by one to find the culprit (see below flow chart for troubleshooting cycle).

    If its not a plugin conflict then please try to add following define in wp-config.php file before /* That's all, stop editing! Happy blogging. */
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    In case above does not work for you then please try adding following code in .htaccess file (at beginning of the file).

    <Directory "/var/www/html">
       AllowOverride All
    </Directory>

    If none of above work for you then please send in FTP and WordPress admin details in following format so we could take a closer look.

    You can send the requested details via our secure contact form in following format.

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Sajid

    Hello Ibnewbie,
    Hope you are doing good today :slight_smile:

    Thanks for sending in FTP and WordPress admin details directly. There was an issue with main.js file, it occured a while ago and our developers fixed it in latest versions.

    I fixed this issue for now by replacing the existing main.js file with the one provided by our developer before.

    I see the version of Upfront is 1.7, but it is still displaying the old UI of editor. May be some files did not get get updated properly.

    Even though, it is working right now but I still recommend you deleting Upfront parent along with Luke and Sara child theme and then try install again from our website to avail latest features and flexibility of Upfront theme.

    In case, this issue return back, then follow the advice here to fix it up:
    https://premium.wpmudev.org/forums/topic/spirit-renders-to-89-92-and-then-stalls#post-1085478

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Ibnewbie

    Hello Sajid!

    Well I uninstalled both Upfront and Luke and Sara and I reinstalled as you suggested. That broke it again.

    I replaced the main.js file as mentioned in your link to the other article. It seems to be working, however, I think the main.js from your link is an older file.

    Plus, if I installed from the link within the WPMUDEV, should that have the latest and greatest files? No need to manually patch?? I should not have to install an older file to make it work. Is there a setting that I need to have configured on my hosting service?

    Thanks!

    Frank...

  • Sajid

    Hello Ibnewbie,
    Hope you are doing good today :slight_smile:

    Yes, when you install from your WordPress Dashboard -> WPMU DEV -> Plugins or Themes, it install latest and stable version of themes/plugins. It seems, you did not updated Upfront parent theme.

    Any way, I have updated the both Upfront Parent and Luke & Sara themes and now it is working perfectly fine on your site.

    I have deleted the existing Upfront parent and child Luke & Sara theme after taking backup. If you had any thing in older versions of themes then just let me know.

    If no then we are all good to go from onward and it's time to build an awesome site using Upfront.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Sajid

    Hello Ibnewbie,
    Hope you are doing good today :slight_smile:

    It should not broke the site automatically. Did you downgraded the Upfront theme or restored a backup ?

    I tried to install the latest version of Upfront and Luke & Sara theme but it is still not loading for me.

    I then replaced main.js file with the one I linked above and it worked fine.

    However, I am bringing it to developer's attention so we could further investigate this issue. Do you have staging/development site where I can make changes ? Or it is okay to do it on your existing site ?

    If you have staging site, then please send in WordPress admin and FTP details via our secure contact form in following format.

    You can send the requested details via our secure contact form in following format.

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Ibnewbie

    I am having a ton o f trouble with the Snapshot pro plugin trying to back up the site to stage one for you. When I try to restore the original site to another domain, it says there's an error then corrupts the entire Wordpress install. I tried it on a couple other domain names, then finally tried it on this original site as a subfolder. It too choked and puked. Not sure how I can get you a staged site when another script of WPMUDEV is not working.

    Any thoughts on how I can get a dev site setup by using someone else's tools?

    Thanks!

    Frank...

  • Sajid

    Hello Ibnewbie :slight_smile:

    Thanks for sending in the login details of staging site. I installed Luke & Sara theme there via WPMU DEV Dashboard plugin, launched Upfront Editor by clicking on the Upfront link on black admin bar on top of the page and it loaded just fine for me.

    For testing, I added an image module, saved changes and it worked too. Tried going back and fourth for a couple of times but it did not broke.

    Does both sites are on same server ?

    Could you please try making changes here and check if it works for you ?

    Take care and have a nice weekend!

    Best Regards,
    Sajid - WPMU DEV Support

  • Ibnewbie

    Hello Sajid!

    Sorry for the delay in responding. To answer your question, both sites are hosted on the same VPS.

    I was able to tinker with both sites over the last few days. I have not been able to 'break' the site like before.

    I noticed there was an update to both Upfront and Luke & Sara today. I updated on both sites. It seems to be very stable at this point.

    The only odd ball thing I saw was that when I entered into Upfront a few times for editing, the editing area came in blurry. It wasn't on a particular page, but on those I tried to edit and it wasn't consistent each time, it happened randomly. The page edited fine and saved fine. Just thought I would let you know.

    Thanks for all your help. I am going to be editing a ton over the next few days. If it acts up again, I will let you know. Otherwise, when I am done editing, and see no issues, I will mark this as resolved.

    Frank...

  • Sajid

    Hello Frank :slight_smile:

    I am really glad to know it is working fine and is stable for you. So you are all set for the making an awesome website.

    I could not see the blurry issue on my own test site. But in case you face this or any issue again then feel free to let us know by creating a separate support ticket.

    We would definitely love to help and fix this issue for you.

    Best Regards,
    Sajid - WPMU DEV Support