UpFront Theme Builder won't accept Hubspot Form JS / HTML Issues

Hello WPMU Dev Support - I've been generally just been having issues working with UpFront and was hoping you'd be able to assist me with troubleshooting them. My overall goal with using the theme Fixer is just to have a Splash Page - no navigation / header area - just the following inside a full screen background:

----LOGO-----
----TEXT------
----HUBSPOT FORM----
--FOOTER TEXT----

1. I've been having an issue placing a JS script form from Hubspot onto my page. As seen in these three screenshots (one, two three) - I placed the code into the JS area, and then nothing happens: the code ends up appearing at the bottom of the screen - broken. Even when I delete the 'code element' the JS area is still appearing at the bottom area. This doesn't appear on the actual site: only on the front-end area. If possible could you example what exactly I'm doing wrong: and how to fix this issue?

2. I used UpFront to create the page I wish to have as the Splash Page: however it isn't on an existing page: is there any way I can have that 'Splash Page Mockup' be a template for an actual page and not just 'for static posts' .

3. I've only been able to spot the UpFront Front-end builder - but I was looking to see if I could edit exclusively HTML (similar to the classic editor in WordPress) but for the entire UpFront area.

I've given you access for this site so any help at all would be greatly appreciated. Looking forward to hearing from you!

  • Adam Czajczyk

    Hello Thomas,

    I hope you're well today and thank you for your questions!

    1. I've been having an issue placing a JS script form from Hubspot onto my page. As seen in these three screenshots (one, two three) - I placed the code into the JS area, and then nothing happens: the code ends up appearing at the bottom of the screen - broken. Even when I delete the 'code element' the JS area is still appearing at the bottom area. This doesn't appear on the actual site: only on the front-end area. If possible could you example what exactly I'm doing wrong: and how to fix this issue?

    I accessed your site but I think the code element is now removed from your layout, is that correct? Some complex codes have to be either "split" to separate HTML/CSS/JS codes or even moved to a separate files and then enqueued into the theme so this may be a case however I'm not able to tell you that without checking an actual code.

    That said, could you please share that HubSpot code with me? You can either upload it here by attaching a .txt file or post it marking it as a code (using post editor "code" tool icon) or create a pastebin.com and share a link to it with me here.

    2. I used UpFront to create the page I wish to have as the Splash Page: however it isn't on an existing page: is there any way I can have that 'Splash Page Mockup' be a template for an actual page and not just 'for static posts' .

    I admit I'm not sure if I'm following you on this. Could you explain that a bit more for me so I could better understand the issue, please?

    3. I've only been able to spot the UpFront Front-end builder - but I was looking to see if I could edit exclusively HTML (similar to the classic editor in WordPress) but for the entire UpFront area.

    Upfront Builder is a visual tool and it won't let you edit entire HTML/JS/CSS of Upfront themes the way WP built-in editor does. In fact, Upfront themes are very different than regular WP themes and it's not advised to edit them directly. Upfront Builder lets you build theme to be used with Upfront from scratch but the usage philosophy is pretty much the same as the use of Upfront editor itself.
    Direct editing of Upfront files may lead to unexpected issues.

    As for the initial issue (question no. 1) please share the code with me and I'll check it and hopefully will be able to help you with this.

    Best regards,
    Adam

  • Thomas

    Hello Adam,
    Thanks for getting back to me!

    1.) Sure, attached is the code I need to insert onto the page.

    2.) Sorry about that, I'll try to clarify. Normally in WordPress under Settings < Reading you set the Front Page Display to either "Your Latest Posts" or you set a static page from the pages you've created from 'Pages'. With UpFront, the page you design via the front-end devloper is only going to appear for the 'Your Latest Posts' correct?

    3.) Thank you for clarifying this for me

    Thank you for the help and I look forward to hearing from you.

  • Dimitris

    Hey there Thomas,

    hope you're doing good and don't mind chiming in! :slight_smile:

    2.) Sorry about that, I'll try to clarify. Normally in WordPress under Settings < Reading you set the Front Page Display to either "Your Latest Posts" or you set a static page from the pages you've created from 'Pages'. With UpFront, the page you design via the front-end devloper is only going to appear for the 'Your Latest Posts' correct?

    Well, it's more accurate to say that this is a custom homepage rather than the main query displaying the posts in frontpage.
    You may not be able to have this homepage as a new layout for other pages, but you can create as much as you want through the rest of the pages and templates already in place in every child theme. For example, Fixer provides a "Blog template" for your "Latest Posts" page.

    From "templates" tab you can choose the one you want for your page. If you make any change at all (e.g. adding a new draggable element), this will trigger the "save new layout" option which gives you the ability to further use it in other pages. :wink:

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.