Upfront theme crashed firewall with too many connections

Hi - I just tried one of the Upfront themes. When I went to customise the front end, it gave me a 'please wait' message for a long time. When I tried to access the site on a new page, and other sites, and SSH, etc, I found the firewall had locked me out due to too many connections. Any ideas?

Thanks

  • Sajid

    Hi @paintstripper,

    Hope you are doing good today :slight_smile:

    Weird, we have never reported this issue before by any other members of community. There could be some mod security issues though that can be ruled out by adding following code in .htaccess file of your WordPress.

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    Add this code at very beginning of the file before WordPress rules.

    If the issue still there then please grant support staff access so I can take a closer look at why exactly its not working.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Nastia

    Hello paintstripper, I hope you are doing well today!

    The code above, that Sajid have posted is disabling a specific security mode, that blocking Upfront to load normally. Some hosting has extra unnecessary security.

    Basically, the mod_security module in Apache is blocking various attacks. But it may also can potentially block common scripts, in our example is blocking the Upfront scripts.

    Usually the mod_security is useful when you ask for the user's information. But, if you are using a 3rd party plugin to gather this information, you don't really need to worry about attacks, a third party plugin and WordPress itself takes very good care of these critical things.

    If this solution will not work for you, then please contact a tech support and ask them to "whitelist" your site in Apache mod_security settings.

    I hope this helps!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.