upfront theme loads very slow

Hi,

newly installed network enabled WP, very few plugin activated (hummingbird and WP super cash) and upfront theme loads in 18-30 sec, other theme loads in 1.7 sec according gtmetrix
can you give me any advise, please? ta

  • Adam Czajczyk

    Hello Janos,

    I hope you're well today and thank you for your question!

    I think that it would be best to start here with making sure that Fixer (actually WordPress) is granted enough memory. If you have "WPMU DEV Dashboard" plugin installed on your site please go to the "WPMU DEV -> Support" page in "Network Admin" dashboard and click on "System Info" button, then switch to PHP tab.

    The "memory_limit" line will tell you how much of a server RAM memory can PHP use (let's say it's 256M for example). Then use this value to add following line to the "wp-config.php" file of your WordPress install:

    define('WP_MEMORY_LIMIT','256M');

    The line should be placed above the "/* That's all, stop editing...." line. Make sure that you replaced 256M with the value found "System info" page. \

    Once this is done, please clear all caches (on site and in your browser) and test it again.

    Let me know if this helped!

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Janos!

    I checked your setup and noticed some issues there:

    1. Your WP is not set to use 256M or server RAM, it's set to use 64M

    You mentioned that there's already the "memory line" in wp-config.php. The line that's there is

    define('WP_MAX_MEMORY_LIMIT','256M');

    and not the

    define('WP_MEMORY_LIMIT','256M');

    These are two different settings, though very often confused. Please add the one I suggested and it will switch WP to use up to 256M or RAM.

    2. The site's running on PHP version 5.3.3 which is quite outdated.

    This may cause performance issues and I'd suggest switching to newer version, at least 5.6.19 or newer. Check your server management panel for that setting as you may be able to make the switch by yourself; in case it wasn't possible please get in touch with your host and ask them if they could do this for you.

    3. Disable Cornerstone

    There's the Cornerstone builder plugin enabled on your main site. Upfront is a "front end page builder" and Cornerstone is as well. These two tools cannot work together on the same site and shouldn't be used along. Just to test performance I temporarily disabled it and it makes the difference. It's enabled back again but in order to use Upfront, disable it.

    These three changes alone should speed up the site. Then we could "benchmark" it again and see if any further changes have to/can be made.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.