Upfront: There has been an error saving your changes

Ughhh! Just made a ton of changes to a new site and lost them ALL! It appears that when I have been saving, I have been getting a message "there has been an error saving your changes" it appeared in Upfront like the changes were being made so I assumed it was an issue. Apparently not! After a refresh the site is back to its original form and all my changes are lost. So frustrating.

I have tried everything I know to get the site to save my changes and it is refusing. I will open support access. Please advise.

Thanks!
Tony

    Adam Czajczyk

    Hello Tony,

    I hope you're well today and thank you for your question!

    I checked your site and it seems this is related to a "mod_security" Apache module. "Mod_scurity" is a module of an Apache web server that is meant to add another security layer to your site. Unfortunately on some hosting accounts it's also causing issues with Upfront as it's set to be to "restrictive" and blocks access to some resources.

    In order to fix it try following steps:

    1. Login to your cPanel (or other server management panel that you are using) and look for "mod_security" settings; if there's such option use it to disable "mod_security" for your site's domain.

    2. If there's no such setting, try adding following code at the very beginning of the ".htaccess" file of your WP install (do not remove anything that's already there, just add these lines):

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off 
    SecFilterRemove 00318
    </IfModule>

    In case it didn't work but broke your site, remove that code and the site should work fine again.

    3. If none of the above works, please get in touch with your host tech support and ask them if they could disable mod_security for you or at least white-list your domain in "mod_security" settings.

    Best regards,
    Adam

    Tony

    Hi Adam,
    I will work on this. So far I am having trouble getting access to my .htaccess folder in my cPanel. What I can tell you is that I have a site that is working just fine that is on the same host. The new site is an add-on to that hosted site. So that leads me to believe that mod_security isn't the issue? Because it that was our issue wouldn't we be having the same issue on both sites?

    I will keep working on the .htaccess thing in the mean time. Ideally I would rather not disable mod_security, if I don't have to.

    Thanks!
    Tony

    Tony

    Hey Adam,
    Was able to access .htaccess and add the code that you suggested. This is what I ended up with:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    SecFilterRemove 00318
    </IfModule>
    
    # END WordPress

    I am still getting the error when I try to save my work in Upfront. Any other ideas?

    Thanks!
    Tony

    Adam Czajczyk

    Hello Tony!

    Thank you for your replay.

    The fact that you got other site on the very same server and Upfront is working there is a valuable information and it indeed suggests that "mod_security" may not be a reason here.

    I suggested this because of errors showing up in browser console that most often the same in case of "mod_security" issue. There's however another equally common tweak worth giving a try - rising WP memory limit. To do this, please make sure that following line is in your "wp-config.php" file:

    define('WP_MEMORY_LIMIT','256M');

    The line should be located above the "/* That's all, stop editing! */" line.

    Give it a try please and let me know if that worked. In case it didn't, a more in-depth investigation will be necessary and I'll ask you for direct access credentials to the site (I'll let you know how to send them securely to me).

    Best regards,
    Adam