Upfront + Woocommerce Compatability

How do I go about enabling WooCommerce compatability? Right now the page CSS / format is broken. I tried following the instructions on WooCommerce's website, but I don't see a page.php to rename nor the php code to modify. I am using Upfront's Spirit theme.