Upfront - WYSIWIG Issues; Cursor position behaviour is inconsistent

I'd like to preface this email by saying I really appreciate what Upfront has to offer, we run a managed hosting company with thousands of Wordpress sites, and look forward to recommending this framework!

Onto my question - so a simple text box in Upfront in Chrome / Mac, what happens consistently for me, is that if there is existing text, where I place my cursor is not where the text will resume when I type. I need to cut and paste the text again, for the typing cursor to work again.

I hope that makes sense, and you are either aware of this issue or have replicated it before and can recommend a better work-around. Obviously in this particularly case, it makes editing existing text frustrating!

Thanks,
Luyen

  • Charles
    • Site Builder, Child of Zeus

    I have experienced the same thing, and it is quite frustrating. There are also some formatting issues within the text box that need to be addressed.
    My work around is simple, and there are two reasons I do it this way:
    I write the content in a TextEdit (Mac) window, proof it and get it ready to pop into the text box. It is a lot easier to edit there.

    It also provides documentation and a quick backup of the content.

    My understanding is that any elements entered in the UF editor are not saved as they would be if entered in the normal backend editor.

    I found this out when I had to totally rebuild my site from scratch because of the page-overwrite bug in the earlier version.

    Hope that helps in the short run, and I am sure they will work on it for a future version.

    • Luyen
      • WPMU DEV Initiate

      Hi Charles! Thanks for taking the time, yes I started doing the same thing and thought there must be a better way (or i'm doing something wrong).

      Be lovely if there was a way to switch between WYSIWIG / HTML mode, i guess the code droppable element could do that.

      By the way, is there a Theme manager from WPMU to track core changes to Upfront parent theme, just wondering since it's not committed to the Wordpress SVN repo if I have to manage updates manually.

  • Vaughan
    • Support/SLS MockingJay

    Hi Luyen,

    Hope you're well?

    I'm a little unsure of your issue, and whereabouts you mean.

    Is there any chance you could screencast as a video to show us exactly what it's doing to you so we're on the same page so to speak? I don't have a mac as i'm on linux, so it might not actually be happening for me.

    Only screencast I know of unfortunately is http://www.techsmith.com/jing.html

    Unless you already have one to use already.

    Thanks

  • Luyen
    • WPMU DEV Initiate

    Hi there - it appears the issue has been fixed after I ugpraded the Upfront parent theme from 1.6.4 to 1.7.x. I haven't been able to reproduce the issue, but in a nutshell - the issue was wherever i put my cursor in a textarea to type, it wouldn't respect that position and characters would appear in a different position making it impossible to write anything.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.