Upfront/Spirit Posts Widget

I have been trying to figure this out, getting nowhere for a couple hours now...

I'm editing the front page of my site in Upfront, and used the Posts widget. I want to display the latest 5 posts and I would like the layout so the thumbnail is on the left of the excerpt.

I could not find where to set the number of posts (five), and editing the Upfront/default CSS to achieve my layout was not getting me anywhere.

My apologies for the two questions in one... Would you be able to shed some light on these two inquires? (If it will at all help, I enabled support access from the WPMU DEV Dashboard).

Many thanks! :upside_down:

  • Predrag Dubajic

    Hey Clyde,

    Hope you're doing well today :slight_smile:

    I have created one page on your site with posts element added, you can check it out on yourdomain.com/test-page/ and here's what I did.

    First I added new Posts Element and selected Posts List, it was showing only one post since your other posts were set as draft, I've also created another post and you can see it displays there now.

    When you now select Posts Element and click on settings, in sidebar you can check which options I used to get this look.

    In General Settings you'll see that I selected 5 posts to be shown, then you can expand Posts Parts Settings where you can enable/disable different post parts (title, content, author, etc.) and next to each element you can click on Edit for additional option.

    And for the last part, Appearance, you will see that I have created new preset and there I added some CSS to make the text go next to featured image.

    You should be able to create exact one you want based on this test page but if there's anything unclear let us know :slight_smile:

    Best regards,
    Predrag

  • Clyde W.

    Hello Predrag,

    I am reopening this thread because I realized that one thing about the homepage CSS for the posts widget is still off:

    The date is missing. I tried to add it in and that was very simple. However, it seems to be ignoring the CSS. I made sure the CSS for the date settings in the "custompostlist" preset you had added in there earlier in this thread was the same as the "archive" preset.

    So I am still at a minor loss with this... Any ideas for how to get the date to show the same in the "custompostlist" preset as in the "archive" preset?

    Thanks! :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.